Opened 7 years ago

Closed 6 years ago

#16298 closed defect (fixed)

Dialog: href content not positioning correctly

Reported by: lee Owned by: bill
Priority: high Milestone: 1.9
Component: Dijit Version: 1.8.1
Keywords: Cc:
Blocked By: Blocking:

Description

There looks to be a problem with loading external content into a Dialog where it positions top above the viewport. domGeometry.position(node) isn't calculated properly as compared to content loaded inline.

I've attached a simple test case. I've attached a "patch" though it isn't one and just a demonstration how to improve positioning. It means _position() would be called 3 times (from show, onLoad and onLoad again) rather than twice, it's still not correct though, the "patch" can only be used with #16172

I added some console logging in _position() to show the domGeometry.position(node) calculations

Inline content

bb: h: 298.1833190917969,w: 1158.5,x: 8,y: 130.86666870117188

External content

bb: h: 70,w: 128,x: 8,y: 130.86666870117188
 -- second call from onLoad
bb: h: 1538,w: 689,x: 576,y: 119

I can call resize in my own code if I connect to the Dialog.onLoad however it seems like that should be managed internally

Attachments (3)

dialog_externalcontent_positionbug.html (8.1 KB) - added by lee 7 years ago.
test html file
externaldialogcontent.html (6.8 KB) - added by lee 7 years ago.
external dialog content
dialogexternalcontentbug.patch (539 bytes) - added by lee 7 years ago.
example patch

Download all attachments as: .zip

Change History (7)

Changed 7 years ago by lee

test html file

Changed 7 years ago by lee

Attachment: externaldialogcontent.html added

external dialog content

Changed 7 years ago by lee

example patch

comment:1 Changed 7 years ago by bill

#11924 is a duplicate of this ticket.

comment:2 Changed 7 years ago by bill

Summary: dijit dialog href content not positioning correctlyDialog: href content not positioning correctly

comment:3 Changed 6 years ago by bill

Milestone: tbd1.9
Priority: undecidedhigh

comment:4 Changed 6 years ago by bill

Resolution: fixed
Status: newclosed

In [31075]:

size dialog after href content loaded, fixes #16298 !strict

Note: See TracTickets for help on using tickets.