Opened 7 years ago

Closed 7 years ago

#16254 closed defect (duplicate)

tests/json.js test serializeCircular crashes Rhino

Reported by: andybalaam Owned by:
Priority: undecided Milestone: tbd
Component: Core Version: 1.8.1
Keywords: Cc:
Blocked By: Blocking:

Description

When I run the JSON tests with Rhino I get this:

$ java -jar util/shrinksafe/js.jar dojo/dojo.js baseUrl=file://$PWD/dojo load=doh test=dojo/tests/json

------------------------------------------------------------
The Dojo Unit Test Harness, $Rev: 23869 $
Copyright (c) 2011, The Dojo Foundation, All Rights Reserved
loading test dojo/tests/json
------------------------------------------------------------ 

32 tests to run in 1 groups
------------------------------------------------------------
GROUP "tests.json" has 32 tests to run
Exception in thread "Thread-29" java.lang.OutOfMemoryError: GC overhead limit exceeded
	at org.mozilla.javascript.NativeArray.<init>(NativeArray.java:90)
	at org.mozilla.javascript.NativeArray.jsConstructor(NativeArray.java:474)
	at org.mozilla.javascript.NativeArray.execIdCall(NativeArray.java:259)
	at org.mozilla.javascript.IdFunctionObject.call(IdFunctionObject.java:127)
	at org.mozilla.javascript.BaseFunction.construct(BaseFunction.java:328)
	at org.mozilla.javascript.Context.newObject(Context.java:1406)
	at org.mozilla.javascript.ScriptRuntime.newArrayLiteral(ScriptRuntime.java:3362)
	at org.mozilla.javascript.Interpreter.interpretLoop(Interpreter.java:3705)
	at org.mozilla.javascript.Interpreter.interpret(Interpreter.java:2484)
	at org.mozilla.javascript.InterpretedFunction.call(InterpretedFunction.java:162)
	at org.mozilla.javascript.optimizer.OptRuntime.callName0(OptRuntime.java:108)
	at org.mozilla.javascript.gen.c2._c8(Unknown Source)
	at org.mozilla.javascript.gen.c2.call(Unknown Source)
	at org.mozilla.javascript.ContextFactory.doTopCall(ContextFactory.java:401)
	at org.mozilla.javascript.ScriptRuntime.doTopCall(ScriptRuntime.java:3003)
	at org.mozilla.javascript.gen.c2.call(Unknown Source)
	at org.mozilla.javascript.Context$1.run(Context.java:488)
	at org.mozilla.javascript.Context.call(Context.java:499)
	at org.mozilla.javascript.Context.call(Context.java:486)
	at org.mozilla.javascript.JavaAdapter.callMethod(JavaAdapter.java:538)
	at adapter1.run(<adapter>)
	at java.lang.Thread.run(Thread.java:679)

(With the Oracle and IBM versions of Java 1.7)

When I comment out the test "serializeCircular" from tests/json.js the other tests pass fine.

Change History (1)

comment:1 Changed 7 years ago by bill

Component: TestFrameworkCore
Resolution: duplicate
Status: newclosed

Duplicate of #15497.

Note: See TracTickets for help on using tickets.