Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#16245 closed task (fixed)

[PATCH][CCLA] dijit.layout clean up layout test pages for accessibility

Reported by: mikeb Owned by: bill
Priority: undecided Milestone: 1.8.4
Component: Dijit Version: 1.8.1
Keywords: Cc:
Blocked By: Blocking:

Description

Update all of the layout test pages (except those in the /robot/ folder) to be more accessible. This will help for accessibility regression testing in the future. Most of the changes were adding lang=en to <html>, role=main to <body>, and adding appropriate aria-label or <label>s.

Attachments (2)

layout-tests-a11y.patch (44.9 KB) - added by mikeb 7 years ago.
update of the dijit/tests/layout test pages for accessibility, please proxy commit for Michael Billau CCLA on file with IBM
29882-backport.patch (43.5 KB) - added by mikeb 7 years ago.
Backport of #16245 to 1.8 branch for accessibility, please proxy commit for Mike BIllau CCLA on file

Download all attachments as: .zip

Change History (7)

Changed 7 years ago by mikeb

Attachment: layout-tests-a11y.patch added

update of the dijit/tests/layout test pages for accessibility, please proxy commit for Michael Billau CCLA on file with IBM

comment:1 Changed 7 years ago by bill

Milestone: tbd1.9

OK, thanks. I went over your changes and fixed a few missing closing angle brackets. FYI, webstorm still complains about the <input> tags with aria-label attributes; it wants a real <label> node.

comment:2 Changed 7 years ago by bill

Resolution: fixed
Status: newclosed

In [29882]:

A11y updates for dijit/layout tests, patch from Mike Billau (IBM, CCLA), thanks!

Fixes #16245.

Changed 7 years ago by mikeb

Attachment: 29882-backport.patch added

Backport of #16245 to 1.8 branch for accessibility, please proxy commit for Mike BIllau CCLA on file

comment:3 Changed 7 years ago by mikeb

Hello, would it be possible to backport these test page fixes to 1.8? This would make it easier to do accessibility verification testing on 1.8 branch as well as make it easier to backport some other a11y fixes. I created 29882-backport.patch for this. Thanks.

comment:4 Changed 7 years ago by bill

Milestone: 1.91.8.4
Type: defecttask

Sure, since they are test fixes we don't have to worry about destabilizing the release. I'll check in your fixes after rerunning the regression.

comment:5 Changed 7 years ago by bill

In [30289]:

Backport accessibility fixes to dijit layout test files to 1.8 branch, patch from Mike Billau (IBM, CCLA), thanks! Refs #16245.

Note: See TracTickets for help on using tickets.