Opened 7 years ago

Closed 5 years ago

Last modified 5 years ago

#16196 closed enhancement (fixed)

[patch][cla] Cannot pass options to optimizer

Reported by: Colin Snover Owned by: Colin Snover
Priority: high Milestone: 1.9
Component: BuildSystem Version: 1.8.1
Keywords: Cc: James Thomas
Blocked By: Blocking:

Description

A user recently requested that sourcemaps be created and made available for the copy of Dojo that is on Google CDN. This should be possible, but the build tool does not allow flags to be passed to the optimizer. There should be a way to pass through optimizer options.

Change History (11)

comment:1 Changed 7 years ago by James Thomas

Cc: James Thomas added

This ticket adds support for source map generation into the Dojo build process http://bugs.dojotoolkit.org/ticket/15232

If this feature got merged into trunk it would be to simple to do...

comment:2 Changed 7 years ago by Colin Snover

In [30044]:

Add Uglify optimizer to build system. Fixes #14684. Also introduces some ability to pass options using the optimizeOptions key though it is unclear how well this works at this point. Refs #16196. !strict

comment:3 Changed 6 years ago by Rawld Gill

Milestone: tbd1.9
Status: newassigned

comment:4 Changed 6 years ago by Rawld Gill

Priority: undecidedhigh
Type: defectenhancement

comment:5 Changed 6 years ago by Rawld Gill

Milestone: 1.91.10

Punting to 1.10 since making the work with node is not simple.

comment:6 Changed 6 years ago by Rawld Gill

#16601 is a duplicate of this ticket.

comment:7 Changed 5 years ago by jmorrin

optimizeOptions are passed to both the closure compiler and to uglify. I have opened a PR documenting the use of optimizeOptions. https://github.com/dojo/docs/pull/101

comment:8 Changed 5 years ago by dylan

Summary: Cannot pass options to optimizer[patch][cla] Cannot pass options to optimizer

comment:9 Changed 5 years ago by dylan

Owner: changed from Rawld Gill to Colin Snover

comment:10 Changed 5 years ago by Colin Snover

Resolution: fixed
Status: assignedclosed

This is either fixed or patchwelcome; we’ll see if the documentation work helps.

comment:11 Changed 5 years ago by bill

Milestone: 1.101.9

Marking as 1.9 since that's where the code went into.

Note: See TracTickets for help on using tickets.