Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#16177 closed defect (fixed)

[regression] CheckedMultiSelect gives 'scope["_onHover"] is null'

Reported by: BryanRJ Owned by: bill
Priority: undecided Milestone: 1.8.2
Component: DojoX Form Version: 1.8.0
Keywords: Cc:
Blocked By: Blocking:

Description

JSFiddle example at http://jsfiddle.net/6QGNZ/ .

In dojo 1.7.3, the given code creates a drop-down checkedmultiselect.

In dojo 1.8.1, it throws an exception complaining about scope_onHover? in lang.hitch.

Change History (7)

comment:1 Changed 7 years ago by bill

Because _CheckMultSelectMenuItem.html has:

dojoAttachEvent="onmouseenter:_onHover,onmouseleave:_onUnhover,...

comment:2 Changed 7 years ago by bill

Milestone: tbd1.8.2
Owner: changed from dante to bill
Status: newassigned

comment:3 Changed 7 years ago by bill

Resolution: fixed
Status: assignedclosed

In [29838]:

Remove unwanted attach-event from _CheckedMultiSelectMenuItem template, fixes #16177 on trunk.

comment:4 Changed 7 years ago by bill

In [29839]:

Remove unwanted attach-event from _CheckedMultiSelectMenuItem template, fixes #16177 on 1.8 branch.

comment:5 Changed 7 years ago by bill

Version: 1.8.11.8.0

comment:6 Changed 7 years ago by bill

#16189 is a duplicate of this ticket.

comment:7 Changed 7 years ago by bill

Summary: CheckedMultiSelect gives 'scope["_onHover"] is null'[regression] CheckedMultiSelect gives 'scope["_onHover"] is null'
Note: See TracTickets for help on using tickets.