Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#16168 closed defect (invalid)

Dojo Toolkit SDK 1.8.1, 1.8.0

Reported by: tsofist Owned by: tsofist
Priority: undecided Milestone: tbd
Component: General Version: 1.8.1
Keywords: Cc:
Blocked By: Blocking:

Description

Since I'm developing it on the SDK version, I noticed that the SDK version dojo contains outdated modules. Such as modules of "dojox\wire\ml\", while in "Dojo Toolkit Release" all correct. And lastly, to upgrade from 1.8.0 to 1.8.1 parser was triggered only by hand ("parseOnLoad = true" in dojoConfig) in SDK-version. Can you clean up the SDK-version? Pardon my English.

Change History (4)

comment:1 Changed 7 years ago by bill

Owner: set to tsofist
Status: newpending

About the parser problem, it's hard to believe the behavior changed between 1.8.0 and 1.8.1, but if you can make a test case (a single HTML file attached using the "Attach file" button then please file another ticket against the parser, with instructions on how to reproduce the problem.

About "contains outdated modules", I'm not sure what you mean. Are you saying that the http://download.dojotoolkit.org/release-1.8.1/dojo-release-1.8.1/ contains dojox/wire/ml, but the zip files in http://download.dojotoolkit.org/release-1.8.1/ don't?

comment:2 Changed 7 years ago by tsofist

Status: pendingnew

Bill, thanks for the reply. I mean, I downloaded archive http://download.dojotoolkit.org/release-1.8.1/dojo-release-1.8.1-src.zip - this SDK-version. If you unzip the file, and look for files containing obsolete type declaration "dojo.provide(", you'll find that the entire project is littered with these ads. This is correct? Because version "http://download.dojotoolkit.org/release-1.8.1/dojo-release-1.8.1.zip "does not contain similar ads.

I even think it makes no sense to send an example, because this is the problem, if you do not think - an example would be a bit later.

Thanks.

Last edited 7 years ago by tsofist (previous) (diff)

comment:3 Changed 7 years ago by bill

Resolution: invalid
Status: newclosed

Oh, this is expected. Some files/packages, particularly less popular packages in dojox/, haven't been converted to the new AMD format. Dojo.provide() and dojo.require() will be supported until dojo version 2.0, so any/all projects that are upgraded to run against 2.0 will be upgraded to use the AMD format, but not necessarily before then.

Regarding http://download.dojotoolkit.org/release-1.8.1/dojo-release-1.8.1-src.zip vs. http://download.dojotoolkit.org/release-1.8.1/dojo-release-1.8.1.zip, both versions are using dojo.provide(), but the latter has a wrapper added by the build system:

// wrapped by build app
define("dojox/wire/ml/Service", ["dijit","dojo","dojox","dojo/require!dijit/_Widget,dojox/xml/parser,dojox/wire/_base,dojox/wire/ml/util"], function(dijit,dojo,dojox){
dojo.provide("dojox.wire.ml.Service");

dojo.require("dijit._Widget");
dojo.require("dojox.xml.parser");
dojo.require("dojox.wire._base");
dojo.require("dojox.wire.ml.util");

Furthermore, the compressed (shrinksafe'd) version of the files still have dojo.provide() but you probably didn't notice because of the compression, which in the example below changed "dojo" to "_2":

//>>built
define("dojox/wire/ml/Service",["dijit","dojo","dojox","dojo/require!dijit/_Widget,dojox/xml/parser,dojox/wire/_base,dojox/wire/ml/util"],function(_1,_2,_3){
_2.provide("dojox.wire.ml.Service");
_2.require("dijit._Widget");
_2.require("dojox.xml.parser");
_2.require("dojox.wire._base");
_2.require("dojox.wire.ml.util");
_2.declare("dojox.wire.ml.Service",_1._Widget,

So, I don't think there's an issue here. If you want to help convert some of the old files to AMD, that would be great, and you can file tickets with patches. But I don't there's a bug, so I'm going to close this ticket.

Last edited 7 years ago by bill (previous) (diff)

comment:4 Changed 7 years ago by tsofist

Thank you Bill. Unfortunately I do not have much free time to do a translation of such modules in AMD mode. Especially now, the modules I needed only to prepare for the transition to 2.0, because DojoX will be disbanded. So I'd like to emphasize that the application using DojoX (and not only), built on http://download.dojotoolkit.org/release-1.8.1/dojo-release-1.8.1-src.zip, and without the assembly may or may not earn. Thank you. Issue resolved.

Note: See TracTickets for help on using tickets.