Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#16167 closed defect (fixed)

[regression] dijit.form.select doesn't dropdown on android devices

Reported by: Mark DeMichele Owned by: bill
Priority: undecided Milestone: 1.8.2
Component: Dijit Version: 1.8.0
Keywords: Cc:
Blocked By: Blocking:

Description

There seems to be a bug with dijit.form.Select which causes android devices to not dropdown the menu. Specifically, the bug seems to originate in dijit/_HasDropDown.js.

I found the cause can monkey patched it in my application, though I'm not 100% positive, if my patch breaks older versions of android. The problem is centered around the fix that simulated a mousedown/mouseup on mobile devices.

_onDropDownMouseUp conditionally sets this._justGotMouseUp to true if it's an ios device.

_onDropdDownClick says, if has("touch") && ! this._justGotMouseUp then simulate a mousedown/mouseup.

The problem is that on the latest android devices, the _onDropDownClick get's called and _justGotMouseUp is fall so it runs this code, but it already brought up the dropdown so I subsequently closes it.

For my fix, I changed the _onDropDownClick to use has("ios"), but I wonder if a better fix would be to change _onDropDownMouseUp to use has("touch"). Not sure.

In either case, someone more knowledgeable of this code should fix it so it works on android devices.

Thanks, Mark

Change History (3)

comment:1 Changed 7 years ago by bill

Milestone: tbd1.8.2
Status: newassigned
Summary: dijit.form.select doesn't dropdown on android devices[regression] dijit.form.select doesn't dropdown on android devices

Thanks for catching that, looks like I messed up in [29199] by changing one has("ios") to has("touch"), but not the other one.

Last edited 7 years ago by bill (previous) (diff)

comment:2 Changed 7 years ago by bill

Resolution: fixed
Status: assignedclosed

In [29832]:

Fix Select dropdown opening on android, due to "typo" in [29119], fixes #16167 and refs #15512 on trunk/ !strict.

comment:7 Changed 7 years ago by bill

In [29833]:

Fix Select dropdown opening on android, due to "typo" in [29119], fixes #16167 and refs #15512 on 1.8/ branch !strict.

Note: See TracTickets for help on using tickets.