Opened 7 years ago

Closed 7 years ago

#16165 closed defect (wontfix)

_TextBoxMixin.selectInputText not working correctly on Firefox?

Reported by: Paul Christopher Owned by: Paul Christopher
Priority: undecided Milestone: tbd
Component: Dijit - Form Version: 1.8.0
Keywords: Cc:
Blocked By: Blocking:

Description

Description

When choosing by keyboard a FilteringSelect's option with a very long text, Firefox displays it like this:

Every other browser displays it like this:

It seems to have something to do with _TextBoxMixin.selectInputText. Calling

   _TextBoxMixin.selectInputText(myInput.textbox)

displays in FF like this:

Every other browser displays it like this:

However calling

   myInput.select()

seems to work correctly on all browsers and displays like this:

Steps to reproduce the issue

  • Run the attached test case. Click in the FilteringSelect and open the drop down using the down arrow. Select the long option. In FF, the option is displayed from backwards. Every other browser displays it from the beginning
  • Now click on the button "this.textbox.select". This works in every browser.
  • Now click on the button "_TextBoxMixin.selectInputText(this.textbox)". FF shows the above behaviour, i.e. displays the text from the end. All other browser display the text beginning from the start.

Attachments (5)

testTextBoxSelect.html (1.8 KB) - added by Paul Christopher 7 years ago.
Buggy.png (22.2 KB) - added by Paul Christopher 7 years ago.
Correct.png (22.6 KB) - added by Paul Christopher 7 years ago.
FF_Select.png (46.2 KB) - added by Paul Christopher 7 years ago.
IE_Select.png (44.3 KB) - added by Paul Christopher 7 years ago.

Download all attachments as: .zip

Change History (9)

Changed 7 years ago by Paul Christopher

Attachment: testTextBoxSelect.html added

Changed 7 years ago by Paul Christopher

Attachment: Buggy.png added

Changed 7 years ago by Paul Christopher

Attachment: Correct.png added

Changed 7 years ago by Paul Christopher

Attachment: FF_Select.png added

Changed 7 years ago by Paul Christopher

Attachment: IE_Select.png added

comment:1 Changed 7 years ago by Douglas Hays

Owner: changed from Douglas Hays to Paul Christopher
Status: newpending

Using "select()" doesn't fix the problem of when you typed the first few characters and the autoCompleted characters are also scrolled to the end. I'm not sure how to fix this.

comment:2 Changed 7 years ago by bill

Incidentally, although I don't like FF's behavior either, I'm not sure we can classify its behavior as a bug, rather than "working as intended".

Last edited 7 years ago by bill (previous) (diff)

comment:3 Changed 7 years ago by Paul Christopher

Status: pendingnew

Good to have talked about this. But yes both of you are right: FF's behaviour is not nice, and there is nothing we can do. It is not our fault. So I don't mind closing this issue.

comment:4 Changed 7 years ago by Douglas Hays

Resolution: wontfix
Status: newclosed
Note: See TracTickets for help on using tickets.