Opened 13 years ago

Closed 12 years ago

#1616 closed defect (fixed)

TooltipDialog with href: cause flicker

Reported by: moe Owned by: bill
Priority: high Milestone: 0.9
Component: Dijit Version: 0.3
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by moe)

Tooltips that load their content from an URL via href cause a flicker on first load. Under certain conditions it will even cause scrollbar flicker (set "html { height:100% }" to see it).

The problem is visible on http://archive.dojotoolkit.org/nightly/tests/widget/test_Tooltip.html

Try the tooltip on the upper "Alpha"-selectbox. On first load it will flicker *very shortly* in the lower left screen-area before it jumps to its final position. (you will probably have to try multiple times or on a slow computer to see it)

Maybe a "display:none" in the right place would already help to resolve this.

This bug basically makes "href" on tooltips unusable right now because the flicker becomes more visible on more complex layouts (or slower browsers like firefox/linux) and scrollbar-flicker is a showstopper in any case...

I tried to make a vid of the bug but my screencast-software ("wink") is too buggy and slow to pick it up.

Change History (7)

comment:1 Changed 13 years ago by bill

Component: GeneralWidgets
Milestone: 0.5
Owner: changed from anonymous to bill

comment:2 Changed 13 years ago by moe

Description: modified (diff)
Summary: Tooltip with href: can cause scrollbar flickerTooltip with href: cause flicker

comment:3 Changed 12 years ago by bill

Component: WidgetsDijit

comment:4 Changed 12 years ago by dante

i've not seen this behavior in 0.9 ... is it still valid?

comment:5 Changed 12 years ago by bill

For TooltipDialog? this can happen. Problem is that we have to defer positioning and fade-in until after the URL finishes loading.

comment:6 Changed 12 years ago by bill

Summary: Tooltip with href: cause flickerTooltipDialog with href: cause flicker

comment:7 Changed 12 years ago by bill

Resolution: fixed
Status: newclosed

(In [9955]) Defer display of dropdown until the href load finishes, so that it doesn't flicker. Particularly with hte button is near the bottom of the screen, the drop down may appear below the button to start with but then when the data finishes loading it no longer fits there.

This will only work for short load times though. If it takes 3 seconds to load we'd be better off to display the dialog immediately with a "Loading..." message and then reposition it when the data comes in.

Fixes #1616

Note: See TracTickets for help on using tickets.