Opened 7 years ago

Closed 6 years ago

Last modified 6 years ago

#16159 closed defect (duplicate)

Issues with loading some Node.js Modules

Reported by: Kitson Kelly Owned by: Colin Snover
Priority: blocker Milestone: 1.9
Component: Core Version: 1.8.1
Keywords: Cc:
Blocked By: Blocking:

Description

Sometimes when attempting to load certain Node.js modules that might relay on code that attempts to detect if it is running in an AMD environment with dojo/node, it can cause issues where it thinks it should be dealing with define() when in fact it shouldn't and instead return values as part of the module export.

When requiring a module, the scope should be limited via a closure and define "descoped" in order for the code to execute properly.

I have attached a patch which resolves this issue.

Attachments (1)

node.js.patch (380 bytes) - added by Kitson Kelly 7 years ago.
Patches dojo/node to scope out define

Download all attachments as: .zip

Change History (5)

comment:1 Changed 7 years ago by Kitson Kelly

Owner: set to Colin Snover
Status: newassigned

Changed 7 years ago by Kitson Kelly

Attachment: node.js.patch added

Patches dojo/node to scope out define

comment:2 Changed 6 years ago by Colin Snover

Milestone: tbd1.9
Priority: undecidedblocker

ugh, this did not get fixed? thought it did. fixing now.

comment:3 Changed 6 years ago by Colin Snover

Resolution: duplicate
Status: assignedclosed

Duplicate of #16414.
Excuse you kitsonk, creating duplicate tickets, sheesh! :)

comment:4 Changed 6 years ago by Kitson Kelly

Ooops... I don't know how the hell I did this. Sorry.

Note: See TracTickets for help on using tickets.