Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#16155 closed defect (fixed)

[regression] SpellCheck Undefined Variables

Reported by: deejross Owned by: bill
Priority: undecided Milestone: 1.8.2
Component: Editor Version: 1.8.0
Keywords: Cc:
Blocked By: Blocking:

Description

When using the dojox/editor/plugins/SpellCheck plugin with Editor, right-click menus do not work when interactive mode is on. The tooltip dialog for non-interactive mode has some unexpected behavior. After looking through the code, there are several references to the variable "ed", which are not defined in some places. In other places, the correct variable name is "editor". I have attached a diff of the changes I've made in order to make the spell checking feature work.

Attachments (1)

SpellCheck.diff (1.6 KB) - added by deejross 7 years ago.

Download all attachments as: .zip

Change History (4)

Changed 7 years ago by deejross

Attachment: SpellCheck.diff added

comment:1 Changed 7 years ago by bill

Milestone: tbd1.8.2
Owner: set to bill
Status: newassigned
Summary: SpellCheck Undefined Variables[regression] SpellCheck Undefined Variables

Thanks for catching that, I'll check in your fix. Also, marking as regression since it worked in 1.7.

comment:2 Changed 7 years ago by bill

Resolution: fixed
Status: assignedclosed

In [29817]:

Fix undefined variable, spacing, and stray global variable, fixes #16155 on trunk !strict, thanks for catching this deejross.

comment:3 Changed 7 years ago by bill

In [29818]:

Fix undefined variable, spacing, and stray global variable, fixes #16155 on 1.8 branch !strict, thanks for catching this deejross.

Note: See TracTickets for help on using tickets.