Opened 7 years ago

Closed 7 years ago

#16119 closed defect (duplicate)

IE10 JsonRest test timeout

Reported by: haysmark Owned by: Kris Zyp
Priority: undecided Milestone: tbd
Component: Data Version: 1.8.0
Keywords: Cc:
Blocked By: Blocking:

Description

     Error: test timeout in testHeaders
     ERROR IN:
 		 function testHeaders(t){
				var d = new doh.Deferred(),
					error,
					expected = 0,
					received = 0;

				// NOTE: Because HTTP headers are case-insensitive they should always be provided as all-lowercase
				// strings to simplify testing.
				function runTest(method, args){
					expected++;

					store[method].apply(store, args).then(function(result){
						received++;

						if(error){
							return;
						}

						var k;

						for(k in requestHeaders){
							if(!result.headers.hasOwnProperty(k) || "" + result.headers[k] !== "" + requestHeaders[k]){
								error = true;
								d.errback(new Error("Header mismatch in " + method + ": " + k));
								return;
							}
						}

						for(k in globalHeaders){
							if(!result.headers.hasOwnProperty(k) || "" + result.headers[k] !== "" + globalHeaders[k]){
								error = true;
								d.errback(new Error("Global header mismatch in " + method + ": " + k));
								return;
							}
						}

						if(expected === received){
							d.callback(true);
						}
					});
				}

				runTest("get", [ "index.php", requestHeaders ]);
				runTest("get", [ "index.php", { headers: requestHeaders } ]);
				runTest("remove", [ "index.php", { headers: requestHeaders } ]);
				runTest("query", [ {}, { headers: requestHeaders, start: 20, count: 42 } ]);
				runTest("put", [ {}, { headers: requestHeaders } ]);
				runTest("add", [ {}, { headers: requestHeaders } ]);

				return d;
			}
 FAILED test: testHeaders 1007 ms

Change History (1)

comment:1 Changed 7 years ago by bill

Resolution: duplicate
Status: newclosed

Duplicate of #16118.

Note: See TracTickets for help on using tickets.