Opened 7 years ago

Closed 7 years ago

#16100 closed defect (fixed)

[patch][CCLA]Surface resizing fails to resize horizontally on Chrome

Reported by: ztravis87 Owned by: Patrick Ruzand
Priority: undecided Milestone: 1.8.3
Component: DojoX GFX Version: 1.8.0
Keywords: Cc:
Blocked By: Blocking:

Description

When resizing a surface with surface.setDimensions, if the set width is smaller than the current width, the displayed image does not resize. For example, this test page: http://archive.dojotoolkit.org/nightly/dojotoolkit/dojox/gfx/tests/test_resize.html fails to resize horizontally when going from 500x500 to 300x300. I can trigger a resize by inspecting the element or fetching the node by id. This might be a Chrome/Chromium/WebKit? bug - I am running Chromium 18.0.1025.168 on linux and a co-worker has reported the same issue on Chrome 22 (also on linux), but I do not see the issue on FF 14.0.1

Attachments (2)

16100.patch (1.2 KB) - added by Patrick Ruzand 7 years ago.
patch by pruzand (IBM, CCLA)
16100.2.patch (978 bytes) - added by Patrick Ruzand 7 years ago.
new patch to take into account webkit version from uagent

Download all attachments as: .zip

Change History (11)

comment:1 Changed 7 years ago by Patrick Ruzand

Owner: changed from Eugene Lazutkin to Patrick Ruzand
Status: newassigned

This is indeed a Chromium bug. I entered the following ticket https://code.google.com/p/chromium/issues/detail?id=162628

The workaround for chrome is to use the css API : rawNode.style.width = ...

Last edited 7 years ago by Patrick Ruzand (previous) (diff)

Changed 7 years ago by Patrick Ruzand

Attachment: 16100.patch added

patch by pruzand (IBM, CCLA)

comment:2 Changed 7 years ago by Patrick Ruzand

Milestone: tbd1.9
Summary: Surface resizing fails to resize horizontally on Chrome[patch][CCLA]Surface resizing fails to resize horizontally on Chrome

comment:3 Changed 7 years ago by Patrick Ruzand

Reproduced on Chrome (Windows) 23 and canary 25 Reproduced on Safari iOS 6.

Works on Safari iOS 5. Works on Safari Win 5.1.7 Works on Android 4.1, 4.0

comment:4 Changed 7 years ago by Patrick Ruzand

Ok, the criteria seems to be: Webkit/534 and less is OK, >534 is KO. Will update the patch accordingly, and commit the fix.

Changed 7 years ago by Patrick Ruzand

Attachment: 16100.2.patch added

new patch to take into account webkit version from uagent

comment:5 Changed 7 years ago by Patrick Ruzand

Resolution: fixed
Status: assignedclosed

In [30072]:

fix setDimension: workaround webkit regression that does not trigger a reflow/layout when changing svg width with setAttribute. fixes #16100 !strict

comment:6 Changed 7 years ago by Patrick Ruzand

In [30079]:

[backport to 1.8] fix setDimension: workaround webkit regression that does not trigger a reflow/layout when changing svg width with setAttribute. refs #16100 !strict

comment:7 Changed 7 years ago by Patrick Ruzand

Milestone: 1.91.8.2

comment:8 Changed 7 years ago by Patrick Ruzand

Milestone: 1.8.21.8.3
Resolution: fixed
Status: closedreopened

Reopen as 1.8 fix is broken.

comment:9 Changed 7 years ago by Patrick Ruzand

Resolution: fixed
Status: reopenedclosed

In [30178]:

fix surface.setDimensions under Chrome, backport 16461 to 1.8 branch, fixes #16100, refs #16461 !strict

Note: See TracTickets for help on using tickets.