Opened 7 years ago

Closed 7 years ago

#16081 closed defect (wontfix)

Textarea: Border not visible in high contrast mode with FF15

Reported by: mikeb Owned by: mikeb
Priority: undecided Milestone: tbd
Component: Dijit - Form Version: 1.8.0
Keywords: Cc: mikeb, bill
Blocked By: Blocking:

Description (last modified by Douglas Hays)

!Textarea's border line disappears in latest FF when in High Contrast mode. This defect doesn't occur on IE8 and Chrome. This defect occurs on all of the themes.

I tried to fix it by adding CSS code in dijit.css like this:

.dj_gecko .dj_ally .dijitTextBox{
	border-style: outset!important;
	border-width: medium!important;
	border-color: #FFF!important;
	margin:1px!important;
	padding:1px!important;
}

and

.dj_gecko .dj_ally .dijitTextBox textarea{
	border-style: outset!important;
	border-width: medium!important;
	border-color: #FFF!important;
	margin:1px!important;
	padding:1px!important;
}

etc.... However, I could not get this to work, even after trying a few different CSS paths. What is the correct way to add a border to this Textarea in High Contrast?


Configuration instructions to set high contrast and large font mode:

Configure your Web browser to inherit the system color scheme:

Internet Explorer:Select Tools > Internet Options. On the General page tab, select the Colors button. In the Colors dialog box, select the Use Windows colors checkbox.

Firefox:Select Tools > Options…

On the Content page tab, select the Colors… button. In the Colors dialog box, select the Use system colors checkbox. Deselect the Allow pages to choose their own colors, instead of my selections above checkbox.

Apply a high-contrast color scheme in Windows: Press LeftAlt+LeftShift+PrintScreen to open the High Contrast dialog. Select the Settings button to open the settings dialog box. Select the Use high contrast checkbox. Select the Settings button. Select the Use shortcut checkbox. Select one of the high-contrast options from the High contrast appearance scheme list. Recommendation: Use High contrast 1 (large) for your test. For a more complete test, consider testing with more than one high contrast scheme. Press OK button to apply the selection.

Attachments (1)

TextArea in high contrast mode.PNG (19.0 KB) - added by mikeb 7 years ago.

Download all attachments as: .zip

Change History (7)

Changed 7 years ago by mikeb

comment:1 Changed 7 years ago by mikeb

Cc: mikeb bill added

comment:2 Changed 7 years ago by bill

Component: themesDijit - Form
Owner: changed from nonken to Douglas Hays
Summary: dijit.form.TextArea: Border not visible in high contrast mode with FF15TextArea: Border not visible in high contrast mode with FF15

comment:3 Changed 7 years ago by Douglas Hays

Description: modified (diff)
Summary: TextArea: Border not visible in high contrast mode with FF15Textarea: Border not visible in high contrast mode with FF15
Version: 1.8.0

comment:4 Changed 7 years ago by Douglas Hays

Owner: changed from Douglas Hays to mikeb
Status: newpending

mikeb, this is a Firefox bug. Please open a bugzilla report. It also fails natively:

<textarea style="border:2px solid red;">no border</textarea>

I can hack the border-style to be anything else like inset and then it shows up, but it doesn't appear as a solid line then like the default TEXTAREA with no custom-border. This worked well in FF ESR 10 so it's a FF regression.

comment:5 Changed 7 years ago by mikeb

Status: pendingnew

Thanks doughays, it looks like you are right. Unfortunately it looks like this bug has already been reported a while ago (by Becky no less): https://bugzilla.mozilla.org/show_bug.cgi?id=452800 I commented that it worked in FF ESR 10 but is broken now so hopefully that will encourage somebody to work on the bug. I don't really think we should hack up the style since it works with ESR correctly.

comment:6 Changed 7 years ago by bill

Resolution: wontfix
Status: newclosed

OK let's wait for a fix from Mozilla.

Note: See TracTickets for help on using tickets.