Opened 7 years ago

Closed 7 years ago

#16036 closed defect (fixed)

[regression] dojo.dnd.manager() no longer defined

Reported by: Alexandre Owned by: bill
Priority: undecided Milestone: 1.8.2
Component: DnD Version: 1.8.0
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by bill)

Hello people!

I have problem with new DOJO 1.8, any page that uses dojox\mdnd\adapter\DndFromDojo? has the follow bug:

SOUCE: dojox\mdnd\adapter\DndFromDojo?.js

LINE: (51) this._dojoManager = dojo.dnd.manager();

ERROR: _1.dnd.manager is not a function Source

How to test? Run the sample: http://archive.dojotoolkit.org/nightly/dojotoolkit/dojox/layout/tests/test_GridContainer_complete_solution.html

I see these errors in other sources, because dojo.dnd.manager do not exists was replaced for dojo.dnd.Manager (M [uppercase])

Vitorelli

Attachments (1)

dojo.png (30.8 KB) - added by Alexandre 7 years ago.
Firebug error

Download all attachments as: .zip

Change History (5)

Changed 7 years ago by Alexandre

Attachment: dojo.png added

Firebug error

comment:1 Changed 7 years ago by bill

Description: modified (diff)
Milestone: tbd1.8.2
Owner: changed from Eugene Lazutkin to bill
Status: newassigned

One issue is that dojox/mdnd/adapter/DndFromDojo.js wasn't converted properly to AMD: it's still trying to use the dojo variable to get dojo.dnd.manager.

But also, looks like dojo/dnd/Manager.js is not correctly setting dojo.dnd.manager, which is a break in backwards compatibility.

comment:2 Changed 7 years ago by bill

Summary: dojox\mdnd\adapter\DndFromDojo.js BUG![regression] dojo.dnd.manager() no longer defined

The first issue is already addressed in #16029.

comment:3 Changed 7 years ago by bill

In [29755]:

For back-compat, make sure client code can call dojox.dnd.manager() in addition to Manager.manager(). Also fixing one of the AMD conversion errors in dojox/mdnd. Refs #16029, #16036, !strict, fixing them on trunk.

comment:4 Changed 7 years ago by bill

Resolution: fixed
Status: assignedclosed

In [29807]:

Merge [29755] to 1.8 branch, making dojox.dnd.manager() available again, fixes #16029, #16036 !strict.

Note: See TracTickets for help on using tickets.