Opened 7 years ago

Closed 7 years ago

#16031 closed defect (invalid)

typo in dojo/request/notify.js causes document parser to crash

Reported by: fbest Owned by:
Priority: undecided Milestone: tbd
Component: General Version: 1.8.0
Keywords: Cc: Bryan Forbes
Blocked By: Blocking:

Description

component: DOJO and DOC PARSER so leaving it at general

The line causes the document parser to crash with the following traceback:

21 » var hub = lang.mixin(new Evented, {

you have to replace new Evented with new Evented()

and btw: what about reprogramming the whole doc parser? it is unstable and slow...

### TRACE: dojo/request notify.js 5,377 KB PHP Fatal error: Uncaught exception 'Exception' with message 'Line 25, char 27: New statement preceeds unknown' in /root/sandbox/dojo/util/docscripts/lib/parser2/JavaScriptSymbol.php:112 Stack trace: #0 /root/sandbox/dojo/util/docscripts/lib/parser2/JavaScriptArray.php(90): JavaScriptSymbol?->convert() #1 /root/sandbox/dojo/util/docscripts/lib/parser2/JavaScriptArray.php(37): JavaScriptArray?->all() #2 /root/sandbox/dojo/util/docscripts/lib/parser2/JavaScriptArray.php(71): JavaScriptArray?->getType(0, 'JavaScriptFunct?...') #3 /root/sandbox/dojo/util/docscripts/lib/parser2/dojo2.inc(321): JavaScriptArray?->getFunction(0) #4 /root/sandbox/dojo/util/docscripts/generate.php(136): dojo_get_contents('dojo', 'request/n in /root/sandbox/dojo/util/docscripts/lib/parser2/JavaScriptSymbol.php on line 112 Fatal error: Uncaught exception 'Exception' with message 'Line 25, char 27: New statement preceeds unknown' in /root/sandbox/dojo/util/docscripts/lib/parser2/JavaScriptSymbol.php:112 Stack trace: #0 /root/sandbox/dojo/util/docscripts/lib/parser2/JavaScriptArray.php(90): JavaScriptSymbol?->convert() #1 /root/sandbox/dojo/util/docscripts/lib/parser2/JavaScriptArray.php(37): JavaScriptArray?->all() #2 /root/sandbox/dojo/util/docscripts/lib/parser2/JavaScriptArray.php(71): JavaScriptArray?->getType(0, 'JavaScriptFunct?...') #3 /root/sandbox/dojo/util/docscripts/lib/parser2/dojo2.inc(321): JavaScriptArray?->getFunction(0) #4 /root/sandbox/dojo/util/docscripts/generate.php(136): dojo_get_contents('dojo', 'request/n in /root/sandbox/dojo/util/docscripts/lib/parser2/JavaScriptSymbol.php on line 112 make[1]: * [api.xml] Fehler 255 make[1]: Leaving directory `/root/sandbox'

Change History (1)

comment:1 Changed 7 years ago by bill

Cc: Bryan Forbes added
Resolution: invalid
Status: newclosed

AFAIK that's valid syntax. But the problem is that you are using the old desupported doc parser. See https://github.com/wkeese/api-viewer/blob/master/README.rst for instructions on new parser and viewer.

Note: See TracTickets for help on using tickets.