Opened 7 years ago

Closed 7 years ago

#16026 closed defect (duplicate)

[regression] dojo/mouse assumes incorrect button codes in quirks mode in non-IE

Reported by: Kenneth G. Franqueiro Owned by: Kris Zyp
Priority: high Milestone: 1.7.4
Component: Events Version: 1.7.0
Keywords: Cc:
Blocked By: Blocking:

Description

This is a regression which has existed since 1.7.0.

dojo/mouse currently performs the following check when branching for code related to mouse button code matching:

if(has("dom-quirks") || !has("dom-addeventlistener")){ /* old-IE button codes here */ }

This is wrong, since other browsers never supported the button codes that old IE did.

In 1.6 (even 1.6.0), the check is correct:

if(dojo.isIE < 9 || (dojo.isIE && dojo.isQuirks)){

This likely got lost in translation from dojo/_base/event to dojo/mouse.

This should get fixed for 1.7.4 and 1.8.1.

Change History (4)

comment:1 Changed 7 years ago by Kenneth G. Franqueiro

Milestone: tbd1.7.4

comment:2 Changed 7 years ago by Kenneth G. Franqueiro

Priority: undecidedhigh

comment:3 Changed 7 years ago by bill

Dup of #15404.

comment:4 Changed 7 years ago by Kenneth G. Franqueiro

Resolution: duplicate
Status: newclosed

Duplicate of #15404.
OK, I'll close this as a duplicate; I've updated the status of the other one.

Note: See TracTickets for help on using tickets.