Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#16013 closed defect (fixed)

[regression] hccss.js causes IE7 Mixed Content Warning

Reported by: t.crowley Owned by: bill
Priority: undecided Milestone: 1.8.2
Component: General Version: 1.8.0
Keywords: Cc:
Blocked By: Blocking:

Description

Updating from version 1.7.2 to 1.8.0 causes a mixed-content warning in IE7. If I replace dijit/hccss.js with the same file from 1.7.2, the warning doesn't display.

Change History (4)

comment:1 Changed 7 years ago by bill

Milestone: tbd1.8.2
Owner: set to bill
Status: newassigned

Thanks. Well the issue is that

if(has("ie")){
	div.outerHTML = "";		// prevent mixed-content warning, see http://support.microsoft.com/kb/925014
}else{
	win.body().removeChild(div);
}

was changed to

domConstruct.destroy(div);

The larger issue is that domConstruct.destroy() causes that warning, but let's not worry about that until if/when it becomes a problem for someone.

comment:2 Changed 7 years ago by bill

Resolution: fixed
Status: assignedclosed

In [29805]:

Fix mixed content warning on IE7, fixes #16013 on trunk !strict.

comment:3 Changed 7 years ago by bill

In [29806]:

Fix mixed content warning on IE7, fixes #16013 on 1.8 branch !strict.

comment:4 Changed 7 years ago by bill

Summary: hccss.js causes IE7 Mixed Content Warning[regression] hccss.js causes IE7 Mixed Content Warning
Note: See TracTickets for help on using tickets.