Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#15991 closed defect (fixed)

dojox.charting: smart labels for slices with a value of zero / wrong colorizing

Reported by: Paul Christopher Owned by: cjolif
Priority: undecided Milestone: 1.8.1
Component: Charting Version: 1.8.0
Keywords: Cc:
Blocked By: Blocking:

Description

Description

  • Empty smart labels are displayed for slices with a value of zero (which should have no label at all?).
  • It seems that all slices are taken into account when colorizing the chart althoug some slices are not visible. Therefore some slices located next to each other have the same color (which should not be the case? At least the chart would look better if there were a color other than green).

Steps to reproduce the issue

  • In line 109, change y from 0.64 to 0.
  • Run the test case. An empty line is displayed without the text "Egypt".

Attachments (4)

screenshot1.png (41.7 KB) - added by Paul Christopher 7 years ago.
test_pie_smart_label.html (4.7 KB) - added by Paul Christopher 7 years ago.
screenshot.png (136.2 KB) - added by Paul Christopher 7 years ago.
screenshot2.PNG (55.6 KB) - added by Paul Christopher 7 years ago.

Download all attachments as: .zip

Change History (13)

Changed 7 years ago by Paul Christopher

Attachment: screenshot1.png added

Changed 7 years ago by Paul Christopher

Attachment: test_pie_smart_label.html added

Changed 7 years ago by Paul Christopher

Attachment: screenshot.png added

comment:2 Changed 7 years ago by Paul Christopher

Attached test case which gives

comment:3 Changed 7 years ago by cjolif

Owner: changed from Eugene Lazutkin to cjolif
Status: newassigned

comment:4 Changed 7 years ago by cjolif

In [29664]:

refs #15991. Make sure labels of 0 pie slices are not remove because when omitLabels is false we still need to display it.

comment:5 Changed 7 years ago by cjolif

Resolution: fixed
Status: assignedclosed

In [29665]:

fixes #15991. Make sure labels of 0 pie slices are not remove because when omitLabels is false we still need to display it.

comment:6 Changed 7 years ago by cjolif

Milestone: tbd1.8.1

comment:7 Changed 7 years ago by Paul Christopher

It works now but sometimes the labels seem to be displayed "on top" of each other:

No image "screenshot2.png" attached to Ticket #15991

The test data is:

CP/PIR-EW	0
C/REC	0
EB	0
CB	0
Blaupunkt	0
CP/PIR-MD	0	
ST	0	
TT/PUI	0
CP/PIR-JP	0
ETAS	0
UBK Purchasing	0
SE	0
ST/PUI	0
CP/PIR-ND	0
AA	0
C/CTI	0
CP/PIR-NA	0
Virtual Plant Suppliers	0
PA	0
TT	0
DC	1
PT/PUI	1
PT	1
CP/PIR-EE	1
CP/PIR-SD	2
CP/PIR-LA	2
CP/PIR-AP	84
CP/PIR-IN	1577

[Remark: For my use case it would be even better if zero slices would have no line and text at all. If you have so many zero slices it is easier to get only those slices displayed that do contain real data. And if only those slices with data have a label, you can easily perceive them at a glance. Maybe I can find a way to turn off the drawing of the line for my application. At least I know now where to turn of the output of the text ;-) ]

Changed 7 years ago by Paul Christopher

Attachment: screenshot2.PNG added

comment:8 Changed 7 years ago by Paul Christopher

omitLabels:true does the trick of hidding the labels for slices with a value of zero.

comment:9 Changed 7 years ago by cjolif

ok I guess you have your solution with omitLabels: true. We might keep in mind there is room for improvement here however indeed.

Note: See TracTickets for help on using tickets.