Opened 7 years ago

Closed 6 years ago

Last modified 6 years ago

#15988 closed defect (fixed)

dojox/mobile/ScrollableView scrolls slowly and does not accelerate on some devices (Android 4)

Reported by: Eric Durocher Owned by: Eric Durocher
Priority: undecided Milestone: 1.9
Component: DojoX Mobile Version: 1.8.0
Keywords: Cc:
Blocked By: Blocking:

Description

Can be reproduced on a Galaxy Nexus for example, running the Mobile Gallery sample and scrolling the demo list. Scroll is slower than a native app, and it not possible to accelerate by moving the finger quickly.

Attachments (1)

android4scrolling.patch (1.2 KB) - added by Damien Mandrioli 6 years ago.
Improves scrolling behaviour on Android 4

Download all attachments as: .zip

Change History (6)

comment:1 Changed 7 years ago by Adrian Vasiliu

Seems to hold for Galaxy Nexus under Android 4.1, but NOT for the same Nexus under Android 4.0.4...

See also #16012 (exploring the use of "native" scroll as an alternate solution on platforms where our experience scrolling troubles...).

comment:2 Changed 7 years ago by leopatras

I got the same sluggish behavior on several Android 4.0.3 devices , HTC Sensation XL and Huawei Y201 Pro. I need to resort to dojox.mobile.View on those devices to get a usable application.

Changed 6 years ago by Damien Mandrioli

Attachment: android4scrolling.patch added

Improves scrolling behaviour on Android 4

comment:3 Changed 6 years ago by cjolif

Milestone: tbd1.9

comment:4 Changed 6 years ago by cjolif

Resolution: fixed
Status: newclosed

In [30971]:

fixes #15988. Improves scrolling behaviour on Android 4. Thanks Damien Mandrioli (IBM, CCLA). !strict.

comment:5 Changed 6 years ago by cjolif

In [30981]:

refs #15988. Restrict the workaround to Android 4.1+ because it might have undesired consequences on lower versions. !strict.

Note: See TracTickets for help on using tickets.