Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#15984 closed defect (wontfix)

MenuItem: dir=rtl doesn't affect visual order of icon, label, and arrow

Reported by: ahmedasaleh Owned by: bill
Priority: undecided Milestone: tbd
Component: Dijit Version: 1.8.0
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by bill)

Using the file test_Menu.html to test PopupMenuItem BIDI support, it found that the icon of the mirrored dijit.PopupMenuItem is placed wrongly on the left when dir is specified on dijit.PopupMenuItem level.

Attachments (1)

icon_MenuItem.JPG (10.8 KB) - added by ahmedasaleh 7 years ago.
Wrong place of the icon of the mirrored dijit.MenuItem? when dir is specified on widget level

Download all attachments as: .zip

Change History (5)

Changed 7 years ago by ahmedasaleh

Attachment: icon_MenuItem.JPG added

Wrong place of the icon of the mirrored dijit.MenuItem? when dir is specified on widget level

comment:1 Changed 7 years ago by bill

Component: GeneralDijit
Description: modified (diff)
Owner: set to bill

comment:2 Changed 7 years ago by bill

Description: modified (diff)
Resolution: wontfix
Status: newclosed
Summary: Wrong place of the icon of mirrored MenuItemMenuItem: dir setting has no effect

Right, since Menu's are implemented as tables, to control the ordering of the icon, label, and arrow, you have to set the dir on the Menu itself, rather than an individual MenuItem. It's just a limitation due to the implementation, and I don't see anyway to "fix" it.

comment:3 Changed 7 years ago by bill

Summary: MenuItem: dir setting has no effectMenuItem: dir=rtl doesn't affect visual order of icon, label, and arrow

comment:4 Changed 7 years ago by bill

#15982 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.