Opened 7 years ago

Closed 7 years ago

#15957 closed enhancement (fixed)

charting should support bidi mirroring

Reported by: cjolif Owned by: cjolif
Priority: undecided Milestone: 1.9
Component: Charting Version: 1.8.0
Keywords: Cc:
Blocked By: Blocking:

Description

Charting already supports bidi text per #12642, it should also allow display mirroring.

Just as bidi text support it should be an optional module.

Attachments (2)

Charts_Mirroring.patch (37.4 KB) - added by cjolif 7 years ago.
implementation of bidi mirroring, thanks Hossam Katory (IBM, CCLA).
DojoChartSupport.patch (19.1 KB) - added by cjolif 7 years ago.
New implementation that applies correctly against trunk

Download all attachments as: .zip

Change History (25)

comment:1 Changed 7 years ago by cjolif

Milestone: tbd1.9
Owner: changed from Eugene Lazutkin to cjolif
Status: newassigned

comment:2 Changed 7 years ago by cjolif

#16041 is a duplicate of this ticket.

comment:3 Changed 7 years ago by cjolif

#16042 is a duplicate of this ticket.

comment:4 Changed 7 years ago by cjolif

#16043 is a duplicate of this ticket.

comment:5 Changed 7 years ago by cjolif

#16044 is a duplicate of this ticket.

comment:6 Changed 7 years ago by cjolif

#16045 is a duplicate of this ticket.

comment:7 Changed 7 years ago by cjolif

#16046 is a duplicate of this ticket.

comment:8 Changed 7 years ago by cjolif

#16047 is a duplicate of this ticket.

comment:9 Changed 7 years ago by cjolif

#16048 is a duplicate of this ticket.

comment:10 Changed 7 years ago by cjolif

#16049 is a duplicate of this ticket.

comment:11 Changed 7 years ago by cjolif

#16050 is a duplicate of this ticket.

comment:12 Changed 7 years ago by cjolif

#16051 is a duplicate of this ticket.

comment:13 Changed 7 years ago by cjolif

#16052 is a duplicate of this ticket.

comment:14 Changed 7 years ago by cjolif

#16053 is a duplicate of this ticket.

comment:15 Changed 7 years ago by cjolif

#16054 is a duplicate of this ticket.

comment:16 Changed 7 years ago by cjolif

#16055 is a duplicate of this ticket.

comment:17 Changed 7 years ago by cjolif

#16056 is a duplicate of this ticket.

comment:18 Changed 7 years ago by cjolif

#16057 is a duplicate of this ticket.

comment:19 Changed 7 years ago by cjolif

#16060 is a duplicate of this ticket.

comment:20 Changed 7 years ago by cjolif

#16061 is a duplicate of this ticket.

comment:21 Changed 7 years ago by cjolif

#16062 is a duplicate of this ticket.

comment:22 in reply to:  description Changed 7 years ago by yehiased@…

Locale: English Browsers: IE8/Windows 7, FF10/Windows 7, FF10/Linux, Safari/MacOS

Procedure:

1- Set the direction for charts to right to left. (Use dir="rtl")

Actual Result:

Charts and Axes are not mirrored and the axis labels are displayed out of place

Expected Result:

When the direction of the chart is Left to Right (LTR), the chart and axes are displayed correctly and the axis labels are displayed in place.

On setting the direction to be Right to Left (RTL), the charts and axes should be mirrored and the axis labels are displayed in place

Changed 7 years ago by cjolif

Attachment: Charts_Mirroring.patch added

implementation of bidi mirroring, thanks Hossam Katory (IBM, CCLA).

Changed 7 years ago by cjolif

Attachment: DojoChartSupport.patch added

New implementation that applies correctly against trunk

comment:23 Changed 7 years ago by cjolif

Resolution: fixed
Status: assignedclosed

In [30347]:

fixes #15957. Implementation of Bidi mirroring in charting. Thanks Hossam Katory (IBM, CCLA). !strict.

Note: See TracTickets for help on using tickets.