Opened 7 years ago

Closed 7 years ago

#15946 closed defect (fixed)

touch.move event cann't be stopped

Reported by: Evan Owned by: bill
Priority: undecided Milestone: 1.8.1
Component: Events Version: 1.8.0
Keywords: Cc:
Blocked By: Blocking:

Description

This issue only occurs on touch devices, e.g. dojo/_base/event.stop() is not effective and can't stop the touch.move event bubbling to outer div

on(n, touch.move, function(evt){
		console.log('inner div, e.target = ' + evt.target.id);
		event.stop(evt);
		//evt.preventDefault();
});

var n2 = dom.byId("outer");
on(n2, touch.move, function(evt){
		console.log('outer div, e.target= ' + evt.target.id);
});			

Attachments (1)

15964.html (1.2 KB) - added by Evan 7 years ago.
The case to reproduce the issue on iOS, Android

Download all attachments as: .zip

Change History (4)

comment:1 Changed 7 years ago by Evan

Owner: changed from Kris Zyp to bill
Status: newassigned

Changed 7 years ago by Evan

Attachment: 15964.html added

The case to reproduce the issue on iOS, Android

comment:2 Changed 7 years ago by Evan

The issue occur both before or after 15892 fix applied.

Seems to be related with the following code snippet in dojo/touch

move: hasTouch ? touchmove :_handle("mousemove")

changing it to this makes event.stop() effective to touch.move

move: hasTouch ? _handle('touchmove') :_handle("mousemove")

comment:3 Changed 7 years ago by Evan

Milestone: tbd1.8.1
Resolution: fixed
Status: assignedclosed

Fixed as part of [29646], refs #15892

Note: See TracTickets for help on using tickets.