Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#15944 closed defect (invalid)

Dialog: Text inside iFrame is not right-aligned when direction is RTL

Reported by: Alia Naguib Owned by:
Priority: undecided Milestone: tbd
Component: Dijit Version: 1.8.0
Keywords: Cc:
Blocked By: Blocking:

Description

Locale: English Browsers: IE8/Windows 7, FF10/Windows 7

Procedure:

1- Set the direction of the page to right to left (use dir="rtl")

2- Create a dijit.Dialog widget enclosing an iframe

Actual Result:

  • The text inside iframe is not right aligned

Expected Result:

  • Since the direction is RTL, then the text should be left aligned

Attachments (2)

Dialog.js.patch (589 bytes) - added by Douglas Hays 7 years ago.
patch from Hossam Katory (IBM, CCLA)
test_Dialog.html (30.7 KB) - added by Alia Naguib 7 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 7 years ago by bill

Component: GeneralDijit
Resolution: invalid
Status: newclosed
Summary: Text inside iFrame is not right-aligned when direction is RTLDialog: Text inside iFrame is not right-aligned when direction is RTL

Please set component and list test case for every ticket, rather than making me guess.

This sounds like it's not a bug but just how the test file http://download.dojotoolkit.org/release-1.8.0/dojo-release-1.8.0/dijit/tests/test_Dialog.html?dir=rtl works. Probably if you try n a true RTL machine it will work.

Last edited 7 years ago by bill (previous) (diff)

Changed 7 years ago by Douglas Hays

Attachment: Dialog.js.patch added

patch from Hossam Katory (IBM, CCLA)

comment:2 Changed 7 years ago by Alia Naguib

The direction is set in the body tag itself.

Changed 7 years ago by Alia Naguib

Attachment: test_Dialog.html added

comment:3 Changed 7 years ago by bill

OK, now I realize that you are talking about an iframe. Setting the dir on an outer frame will not affect the inner frame. I.e. this case:

<body dir="rtl">
   ...
       <iframe> still LTR </iframe>
</body>

This is expected behavior of HTML, and unrelated to dojo or dijit. I don't think we should be adding special code to deal with iframes for Dialogs.

Note: See TracTickets for help on using tickets.