Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#15943 closed defect (wontfix)

Button Border does not appear when direction is RTL

Reported by: Alia Naguib Owned by: Douglas Hays
Priority: undecided Milestone: tbd
Component: Dijit - Form Version: 1.6.0
Keywords: Cc:
Blocked By: Blocking:

Description

Locale: English Browsers: FF10/Windows 7

Procedure:

1- Set the direction for the page to right to left. (Use dir="rtl")

2- Press the "Show file Dialog" button

Actual Result:

  • The button in the file dialog widow is almost completely hidden

Expected Result:

  • When the direction is left to right (LTR), the following components appear from left to right:

a) Text field

b) Browse button

  • When the direction is right to left (RTL), the expected order of the components is as follows from right to left:

a) Test field

b) Browse button

For some reason only the the Browse button is not visible, only its left border is visible

Attachments (2)

buttonBorder defect.jpg (24.5 KB) - added by Alia Naguib 7 years ago.
The attached figure shows the defect more clearly
Common_rtl.less.patch (327 bytes) - added by Douglas Hays 7 years ago.
patch from Hossam Katory (IBM, CCLA)

Download all attachments as: .zip

Change History (5)

Changed 7 years ago by Alia Naguib

Attachment: buttonBorder defect.jpg added

The attached figure shows the defect more clearly

comment:1 Changed 7 years ago by bill

Component: GeneralDijit - Form
Owner: set to Douglas Hays

comment:2 Changed 7 years ago by Douglas Hays

Resolution: wontfix
Status: newclosed

This is a Firefox issue. We provide minimum styling for input type=file.
Consider the simple page:

<html>
<body>
<input type="file" style="width:13em;direction:rtl;">
<input type="file" style="width:13em;direction:ltr;">
</body>
</html>

The Browse button is cut-off on the rtl INPUT but not the ltr one. Please consider logging a bug report with Mozilla.

comment:3 Changed 7 years ago by bill

#15981 is a duplicate of this ticket.

Changed 7 years ago by Douglas Hays

Attachment: Common_rtl.less.patch added

patch from Hossam Katory (IBM, CCLA)

Note: See TracTickets for help on using tickets.