Opened 7 years ago

Closed 6 years ago

#15933 closed defect (invalid)

MenuBar: MenuItem stays selected even when you move away from it.

Reported by: skamaraj Owned by: skamaraj
Priority: high Milestone: 1.9
Component: Dijit Version: 1.8.0
Keywords: Cc:
Blocked By: Blocking:

Description

Reproduction steps:

  1. Open dijit/tests/test_Menu.html test page on chrome 21 or firefox.
  2. Select on a menu item and focus away to another tab in the browser by clicking it.
  3. Now go back to the test page and try selecting another menu item. DijitMenubar? allows selection of anther dijitMenuItem even though there is one menuitem already selected. Essentially it has more than one menuItem selected.

Change History (5)

comment:1 Changed 7 years ago by bill

Component: GeneralDijit
Owner: set to bill

comment:2 Changed 7 years ago by bill

Priority: undecidedhigh
Summary: DijitMenubar - DijitMenuItem stays selected even when you move away from it.MenuBar: MenuItem stays selected even when you move away from it.

See also #15883.

comment:3 Changed 7 years ago by bill

Milestone: tbd1.9

comment:4 Changed 6 years ago by bill

Owner: changed from bill to skamaraj
Status: newpending

Actually, testing on http://download.dojotoolkit.org/release-1.8.0/dojo-release-1.8.0/dijit/tests/test_Menu.html I don't see that problem, at least on the latest chrome. I click "File" to open the file menu, then switch to another browser tab, and then come back and the selection is gone.

Still happening for you? If so can you give precise instructions against that URL?

comment:5 Changed 6 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.