Opened 10 years ago

Closed 10 years ago

#15931 closed defect (fixed)

[regression] 404 error in dojox/editor/plugins

Reported by: Douglas Hays Owned by: Douglas Hays
Priority: undecided Milestone: 1.7.5
Component: Dojox Version: 1.8.0
Keywords: Cc: Jared Jurkiewicz, Mike Wilcox
Blocked By: Blocking:

Description

Starting with [14805], there's a 404 error thrown when using dojox/editor/plugins with a theme other than tundra. This rule was changed from:
.tundra .dijitButtonNode .dijitArrowButtonInner{
to
.dijitButtonNode .dijitArrowButtonInner{
but this was left in:
background:url(../../../../dijit/themes/tundra/images/spriteArrows.png) no-repeat left top;
I don't know if this rule should be removed, or if the background property should be removed or if additional rules for each theme should be added.

Attachments (1)

15931.patch (2.1 KB) - added by Douglas Hays 10 years ago.
possible fix

Download all attachments as: .zip

Change History (10)

comment:1 Changed 10 years ago by Douglas Hays

Cc: Jared Jurkiewicz Mike Wilcox added
Owner: Adam Peller deleted
Status: newassigned

comment:2 Changed 10 years ago by Douglas Hays

error occurs in dojox/editor/plugins/resources/editorPlugins.css

comment:3 Changed 10 years ago by bill

Owner: set to Mike Wilcox
Summary: 404 error in dojox/editor/plugins[regression] 404 error in dojox/editor/plugins

I don't understand why it gets a 404.

comment:4 Changed 10 years ago by bobz79

Any update on this? The 404 error comes since tundra theme is not there in standard package since dojo 1.7.

Changed 10 years ago by Douglas Hays

Attachment: 15931.patch added

possible fix

comment:5 Changed 10 years ago by Douglas Hays

Milestone: tbd1.9

bill, can you review the attached patch? I didn't see any reason for the wayward rule in editorPlugins.css. dijit.css was being imported AFTER claro.css in a couple of test HTML files causing the .dijitButtonNode .dijitArrowButtonInner selector in dijit.css to have a higher priority than the theme specific rule for .claro .dijitArrowButtonInner.

comment:6 Changed 10 years ago by Douglas Hays

I'm testing via dojox/editor/tests/editorTablePlugs.html?theme=claro using the dropdown arrow in the editor toolbar.

comment:7 Changed 10 years ago by bill

@doughays - At a glance that patch looks good to me. I don't see why that CSS code was there in the first place either.

comment:8 Changed 10 years ago by Douglas Hays

Milestone: 1.91.7.5
Owner: changed from Mike Wilcox to Douglas Hays

comment:9 Changed 10 years ago by Douglas Hays

Resolution: fixed
Status: assignedclosed

In [30126]:

Fixes #15931. Remove duplicate dijit.css test file imports and wayward tundra CSS rule.

Note: See TracTickets for help on using tickets.