Opened 7 years ago

Closed 7 years ago

#15908 closed enhancement (wontfix)

ComboBox: does not filter on focus

Reported by: mbendkowski Owned by: Douglas Hays
Priority: undecided Milestone: tbd
Component: Dijit - Form Version: 1.8.0
Keywords: Cc:
Blocked By: Blocking:

Description

Create a simple dijit.form.Combobox with some initial values. Enter the box and type some text in order to see how the dropdown appears and filters the values. Now click somewhere else of the Combobox to loose focus. Enter the Combobox again and expand. The list will not filter - to accomplish that you need to delete a character and retype it again.

Change History (2)

comment:1 Changed 7 years ago by bill

Component: GeneralDijit - Form
Owner: set to Douglas Hays
Summary: dijit.form.ComboBox does not filter on focusComboBox: does not filter on focus

comment:2 Changed 7 years ago by Douglas Hays

Resolution: wontfix
Status: newclosed
Type: defectenhancement

This is working as intended. Manually searching either with the down arrow or by clicking the down arrow button causes all results to be returned. The rationale is that if a value is already present (either initially or from a previous user-interaction) and the user wants to change it (and hasn't entered any more characters), then it's more likely that it's not filter text since the user would have supposedly finished the filter operation in the previous interaction. In the (hopefully rare) scenario where further searching is desired, the previous value is not overwritten (even when autoCompleting) after a full search so it's straightforward to backspace and retype the previous character to begin filtering again.

Note: See TracTickets for help on using tickets.