Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#15906 closed defect (duplicate)

Modal dialog accessibility issue (a11y) when using IE, Dojo & JAWS

Reported by: nsskumar Owned by:
Priority: undecided Milestone: tbd
Component: Accessibility Version: 1.8.0
Keywords: Cc: mikeb
Blocked By: Blocking:

Description

Description:- Problem distinguishing content of a modal dialog from the underlying parentpage.

When using IE, If a modal dialog is opened using Dojo Dialog, user is able to see and navigate (INSERT + F5)through all the tab focusable elements including the underlying parent page.\

Steps to duplicate this issue:-

  1. Save testModal.html in your local drive
  2. Run JAWS 13
  3. Open testModal.html in IE9 (select allow blocked content if you get the warning)
  4. Press TABs to reach/select “Modal Dialog(Dojo)” button
  5. Press Enter to open the Modal dialog which contains a simple form with 2 fields Name & Location
  6. Press Tab , now the cursor will be in Location Field
  7. Press INSERT+F5 , you will get a list of 4 focusable elements on the modal dialog + “Modal Dialog(Dojo) button” which exists on the underlying parent page. This button should not be listed, since it exists on the parent page and user cannot select this element.

NOTE:- It worked fine in Firefox(version 14)

Attachments (1)

testModal.html (1.5 KB) - added by nsskumar 7 years ago.

Download all attachments as: .zip

Change History (4)

Changed 7 years ago by nsskumar

Attachment: testModal.html added

comment:1 Changed 7 years ago by Douglas Hays

Cc: mikeb added
Component: Dijit - FormAccessibility
Owner: Douglas Hays deleted
Status: newassigned

comment:2 Changed 7 years ago by bill

Resolution: duplicate
Status: assignedclosed

Isn't this a dup of #15905?

Last edited 7 years ago by bill (previous) (diff)

comment:3 Changed 7 years ago by nsskumar

Correct this is duplicate of 15905

Note: See TracTickets for help on using tickets.