Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#15899 closed defect (worksforme)

dijit.form.DateTextBox will not work with conditional comments("if") before "head"

Reported by: qxo Owned by: qxo
Priority: undecided Milestone: tbd
Component: General Version: 1.8.0
Keywords: Cc:
Blocked By: Blocking:

Change History (10)

comment:1 Changed 7 years ago by ben hockey

Owner: set to qxo
Status: newpending

do you have any more specifics of the problem? i don't immediately see an issue with this on chrome but since you mention conditional comments i assume you are having issues with IE. even still... you haven't given much detail about the problem.

comment:2 Changed 7 years ago by bill

The second test case works fine for me on IE8.

comment:3 Changed 7 years ago by qxo

Status: pendingnew

The scond test(http://qxotest.googlecode.com/svn/trunk/dojoTest/testH5bpWithDojoDateWidgetFailed.html) not works in my "IE 8 with compatibility-view"(not always,but switch to compatibility-view will see the problem ) , Firefox 14.0.1 and Google Chrome 21.0.1180.83 m

comment:4 Changed 7 years ago by bill

Unfortunately the second link is broken now, can you fix?

comment:5 Changed 7 years ago by bill

Oh, nevermind, it's this lame VPN server on my machine, when I shut it down I can access the link.

comment:6 Changed 7 years ago by bill

But the second link is working for me on IE8 with all setting (browser mode = IE8 compat, browser mode = IE7, etc)

comment:7 Changed 7 years ago by bill

Resolution: worksforme
Status: newclosed

I tried some more, I cannot reproduce any problem, sorry.

comment:8 Changed 7 years ago by qxo

if using dojo with same domain as test page,it's work fine. but using cdn,will see the problem:(

comment:9 Changed 7 years ago by qxo

It's about locale language problem,not about " conditional comments". dojo do not respect "html element lang attribute" ,just use browser's default language,it's not right! if html element have lang attribute,the dojo default locale should use it!

You can not see problem cause your browser default language is english,try change browser default language to "Chinese(zh-cn)" ,you'll see the problem!

Last edited 7 years ago by qxo (previous) (diff)

comment:10 Changed 7 years ago by bill

Maybe. If you tell me what problem you are seeing then I'll check if I can see it too.

If you are upset that dojo doesn't fully obey a setting like <body lang="zh-cn">, this is expected behavior. You should set data-dojo-config's locale property in this case. See http://dojotoolkit.org/reference-guide/1.8/quickstart/internationalization/specifying-locale.html#quickstart-internationalization-specifying-locale.

Note: See TracTickets for help on using tickets.