Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#15895 closed defect (fixed)

[regression] TabContainer: close icon of last tab not visible

Reported by: bill Owned by: bill
Priority: undecided Milestone: 1.8.1
Component: Dijit Version: 1.8.0
Keywords: Cc:
Blocked By: Blocking:

Description

See test_TabContainer.html. On first TabContainer scroll to right-most tab ("Embedded Layout Widgets"). The close icon is not visible.

Started in [27642].

Change History (3)

comment:1 Changed 7 years ago by bill

Milestone: tbd1.8.1
Status: newassigned

Completely hidden in claro, mostly hidden in tundra, and half-hidden in soria/nihilo.

Last edited 7 years ago by bill (previous) (diff)

comment:2 Changed 7 years ago by bill

Resolution: fixed
Status: assignedclosed

In [29565]:

Need to measure tab button's border-box width or margin-box width, not its content-box width. The old code just happened to work before (more or less) because the button didn't have any padding on it's outer node. Fixes #15895, refs #14663 on 1.8/ branch !strict.

comment:4 Changed 7 years ago by bill

In [29566]:

Need to measure tab button's border-box width or margin-box width, not its content-box width. The old code just happened to work before (more or less) because the button didn't have any padding on it's outer node. Fixes #15895, refs #14663 on trunk/ !strict.

Note: See TracTickets for help on using tickets.