Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#15875 closed defect (fixed)

MenuItem: can't change disabled color w/out using !important

Reported by: haysmark Owned by: bill
Priority: undecided Milestone: 1.8.1
Component: Dijit - LnF Version: 1.8.0
Keywords: Cc:
Blocked By: Blocking:

Description

In dijit.css, you see these lines that get applied to all themes:

.dj_ie .dijit_a11y .dijitMenuItemDisabled,
.dj_ie .dijit_a11y .dijitMenuItemDisabled td,
.dj_ie .dijitMenuItemDisabled *,
.dj_ie .dijitMenuItemDisabled td {
    color:gray !important;
    filter: alpha(opacity=35);
}

The problem is that custom themes inheriting the dijit.css infrastructure can't changed the disabled color.

Change History (4)

comment:1 Changed 7 years ago by bill

Summary: can't change color of disabled menu itemMenuItem: can't change disabled color w/out using !important

Agreed in principle: the themes can override the color but they need to use !important, which we try not to do in theme files. I imagine the !important is there to:

  • solve a precedence issue to make the gray override the color of claro (etc.) enabled MenuItems
  • for dijit_a11y to override theme settings

Do you happen to have a patch to fix this?

comment:2 Changed 7 years ago by bill

Milestone: tbd1.8.1
Status: newassigned

comment:3 Changed 7 years ago by bill

Resolution: fixed
Status: assignedclosed

In [29599]:

Remove !important for MenuItem CSS, IE is working without it (both for disabled MenuItem's and disabled MenuBarItem's), fixes #15875 on trunk.

comment:4 Changed 7 years ago by bill

In [29600]:

Remove !important for MenuItem CSS, IE is working without it (both for disabled MenuItem's and disabled MenuBarItem's), fixes #15875 on 1.8 branch.

Note: See TracTickets for help on using tickets.