Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#15873 closed defect (invalid)

early dates not being displayed

Reported by: gerhard presser Owned by: cjolif
Priority: undecided Milestone: tbd
Component: DojoX Widgets Version: 1.8.0
Keywords: Cc: dg
Blocked By: Blocking:

Description

if I try to use the new dojox/calendar/Calendar to display a date with e.g. startDate < 8:00AM, is not visible in the day/4 day/week (column) view - just in the month (matrix) view.

I don't assume this to be by design!?

Change History (5)

comment:1 Changed 7 years ago by cjolif

Owner: changed from dante to cjolif
Status: newassigned

comment:2 Changed 7 years ago by cjolif

Resolution: invalid
Status: assignedclosed

This is probably due to the default minimum time for these views which is 8am. But you can easily change that. Something like:

<div data-dojo-type="dojox/calendar/Calendar"
data-dojo-props="columnViewProps:{minHours:0, maxHours:24}"></div>

If your issue is different please attach a test case that reproduces it.

comment:3 Changed 7 years ago by gerhard presser

I think that's my problem - but - shouln't these dates be displayed in a kind of 'pre 8:00' line - not showing them looks like 'there are no dates'?

comment:4 Changed 7 years ago by cjolif

Cc: dg added

It seems you are suggesting a different design. I'm not sure which one exactly so it is hard for me to me to suggest you if you can achieve it with the existing component. In any case this is not a defect and usage issue are best discussed on the dojo-interest mailing list.

comment:5 Changed 7 years ago by gerhard presser

I think there should be some kind of hint, that there are events not being displayed.

I'm not sure how this may look like, but hiding them is not good.

Note: See TracTickets for help on using tickets.