Opened 7 years ago

Closed 7 years ago

#15869 closed defect (fixed)

MoveSlice and Tooltip fault if Pie Chart has 'startAngle'

Reported by: Bi11 Owned by: Bi11
Priority: undecided Milestone: 1.8.2
Component: Charting Version: 1.8.0
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by bill)

if a Pie chart set with startAngle, the MoveSlice? and Tooltip will go to a wrong direction.

    ....
    chart.addPlot("default", {
        type: "Pie",
        startAngle: 180
    });
    ....
    new dojox.charting.action2d.Tooltip(chart,"default");
    ...

Attachments (1)

wrong pie.png (10.0 KB) - added by Bi11 7 years ago.
Wrong Pie Move Slice Bug Example

Download all attachments as: .zip

Change History (10)

comment:1 Changed 7 years ago by bill

Component: DojoxCharting
Description: modified (diff)
Owner: changed from Adam Peller to Eugene Lazutkin

comment:2 Changed 7 years ago by cjolif

Owner: changed from Eugene Lazutkin to Bi11
Status: newpending

Can you please be a little be more specific? I have just modified test_events2d.html to put startAngle: 180 is the bottom pie chart and the tooltip works ok. The MoveSlice might need some little improvement but it is not going into "the wrong direction".

Do you have an example that does reproduce the issue?

Thanks.

comment:3 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Changed 7 years ago by Bi11

Attachment: wrong pie.png added

Wrong Pie Move Slice Bug Example

comment:4 Changed 7 years ago by Bi11

modify test_events2d.html, change startAngle and set y in 40,20,10,10

	chart10.addPlot("default", {
		type: "Pie", 
		font: "normal normal 11pt Tahoma", 
		fontColor: "black", 
		labelOffset: -30,
		radius: 80,
		startAngle: -180
	});
	chart10.addSeries("Series A", [
		{y: 40, text: "Red",   color: "red",   stroke: "black", tooltip: "Red is 50%"},
		{y: 20, text: "Green", color: "green", stroke: "black", tooltip: "Green is 25%"},
		{y: 10, text: "Blue",  color: "blue",  stroke: "black", tooltip: "I am feeling Blue!"},
		{y: 10, text: "Other", color: "white", stroke: "black", tooltip: "Mighty <strong>strong</strong><br>With two lines!"}
	]);

The result is also attached. http://trac.dojotoolkit.org/raw-attachment/ticket/15869/wrong%20pie.png

comment:5 Changed 7 years ago by Bi11

Could you reopen this ticket?

comment:6 Changed 7 years ago by cjolif

Milestone: tbd
Resolution: invalid
Status: closedreopened

comment:7 Changed 7 years ago by cjolif

In [29873]:

refs #15869. Fixes issues with MoveSlice? & Tooltip when Pie startAngle is not 0. !strict.

comment:8 Changed 7 years ago by cjolif

Milestone: 1.8.2

comment:9 Changed 7 years ago by cjolif

Resolution: fixed
Status: reopenedclosed

In [29875]:

fixes #15869. Fixes issues with MoveSlice? & Tooltip when Pie startAngle is

not 0 (backport to 1.8). !strict.

Note: See TracTickets for help on using tickets.