Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#15865 closed defect (fixed)

double scrollbar for robot files

Reported by: bill Owned by: bill
Priority: undecided Milestone: 1.8.1
Component: TestFramework Version: 1.8.0
Keywords: Cc: doughays
Blocked by: Blocking:

Description (last modified by bill)

I think from after the changes to support AMD, there's a double scrollbar when running tests, for example in dijit/tests/form/robot/Textarea.html. One on iframe --> html --> body (which is expected), and one on iframe --> html.

Change History (4)

comment:1 Changed 5 years ago by bill

  • Description modified (diff)
  • Milestone changed from tbd to 1.8.1
  • Owner set to bill
  • Status changed from new to assigned
  • Summary changed from double scrollbar in runTests.html to double scrollbar for robot files

comment:2 Changed 5 years ago by bill

  • Cc doughays added
  • Description modified (diff)

Root cause seems to be from this code from #8776:

var emptyStyle = {
        overflow: dojo.isWebKit? 'hidden' : 'visible',
        margin: '0px',
        borderWidth: '0px',
        height: '100%',
        width: '100%'
};
dojo.style(document.documentElement, emptyStyle);

comment:3 Changed 5 years ago by bill

  • Resolution set to fixed
  • Status changed from assigned to closed

In [29505]:

Various DOH robot updates:

  • Don't include dijit code into page with robot test code; dijit should only be loaded in the content iframe.
  • Fix double scrollbar on tests (on IE8) caused by overflow:visible setting on <html>
  • Prefer dojo/domReady! to dojo/ready, in order to support other AMD loaders. However, dojo/ready is still needed for the outer frame to detect when the inner frame (with the content) has completed initializing.
  • Since robot depends on dojo, use domClass.add() and remove() to add dohRobot class to <html> node, to avoid getting a space character in the class string.


Fixes #15865, refs #15616 on trunk/ !strict.

comment:3 Changed 5 years ago by bill

In [29506]:

Various DOH robot updates:

  • Don't include dijit code into page with robot test code; dijit should only be loaded in the content iframe.
  • Fix double scrollbar on tests (on IE8) caused by overflow:visible setting on <html>
  • Prefer dojo/domReady! to dojo/ready, in order to support other AMD loaders. However, dojo/ready is still needed for the outer frame to detect when the inner frame (with the content) has completed initializing.
  • Since robot depends on dojo, use domClass.add() and remove() to add dohRobot class to <html> node, to avoid getting a space character in the class string.


Fixes #15865, refs #15616 on 1.8/ branch !strict.

Note: See TracTickets for help on using tickets.