Opened 7 years ago

Closed 7 years ago

Last modified 5 years ago

#15853 closed defect (fixed)

[patch][CCLA] dijit.TitlePane: missing aria-labelledby and invalid roles on locked pane

Reported by: mikeb Owned by: bill
Priority: undecided Milestone: 1.8.1
Component: Dijit Version: 1.8.0
Keywords: Cc:
Blocked By: Blocking:

Description

The dijit.TitlePane? containerNode has "role='region'" but according to WAI-ARIA specification anything with "role='region'" also should have a label or title (this is for JAWS screen reader accessibility navigation by region).

Patch fixes this by giving the titleBarNode an ID and then using aria-labelledby on the containerNode pointing back to the titleBarNode.

Also fixes a problem where a "locked" TitlePane? had an invalid aria-pressed attribute on the titleNode. This was because setting locked to true also correctly changed the titleBarNode's role from "Button" to "heading" but did not remove the aria-pressed.

Finally the patch fixes up the test page to be more accessible.

Attachments (1)

TitlePane_a11y_labelledby.patch (4.6 KB) - added by mikeb 7 years ago.
adds aria-labelled by on titlePane, fixes locked pane role, please proxy commit for Michael Billau (CCLA on file with IBM)

Download all attachments as: .zip

Change History (5)

Changed 7 years ago by mikeb

adds aria-labelled by on titlePane, fixes locked pane role, please proxy commit for Michael Billau (CCLA on file with IBM)

comment:1 Changed 7 years ago by bill

Milestone: tbd1.8.1

Thanks, looks good.

comment:2 Changed 7 years ago by bill

Resolution: fixed
Status: newclosed

In [29489]:

Add aria-labelledby for TitlePane?, fixes #15853 on trunk/, thanks Michael Billau (CCLA on file with IBM), !strict

comment:3 Changed 7 years ago by bill

In [29490]:

Add aria-labelledby for TitlePane?, fixes #15853 on 1.8/ branch, thanks Michael Billau (CCLA on file with IBM), !strict

comment:4 Changed 5 years ago by bill

#17735 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.