Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#15845 closed defect (fixed)

dojo/store/Cache third argument (options) is no longer optional

Reported by: Kris Zyp Owned by: bill
Priority: undecided Milestone: 1.8.1
Component: Data Version: 1.8.0
Keywords: Cc:
Blocked By: Blocking:

Description

In [28515] on line 35 of Cache.js, the line that provides a default object for options so that the options argument can be optional was inadvertently removed. This regression breaks code (including a couple tests in dgrid) that don't pass a third argument to the Cache constructor.

Change History (6)

comment:1 Changed 7 years ago by Kris Zyp

Owner: set to bill
Status: newassigned

comment:2 Changed 7 years ago by bill

Component: GeneralData
Milestone: tbd1.8.1

Ah sorry I'll put that back.

Looks like you are missing tests for this though (in dojo/tests/store/Cache.js), and tests for the isLoaded callback.

comment:3 Changed 7 years ago by bill

Resolution: fixed
Status: assignedclosed

In [29480]:

options param is supposed to be optional, fixes #15845 on trunk

comment:4 Changed 7 years ago by bill

In [29481]:

options param is supposed to be optional, fixes #15845 on 1.8/ branch

comment:5 Changed 7 years ago by Nick Fenwick

For anyone else googling for the error this bug causes, the message reported tends to be:

Uncaught TypeError: Cannot read property 'isLoaded' of undefined

I spend ages looking into this, unable to find a reference online. An example of the failure: http://dojo-sandbox.net/neek/ccd8d/0

comment:6 Changed 7 years ago by Kris Zyp

#15518 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.