Opened 7 years ago

Closed 3 years ago

Last modified 3 years ago

#15842 closed defect (fixed)

dojox/mobile/ScrollablePane not stopped on touch when scrolling

Reported by: Wouter Hager Owned by: dylan
Priority: low Milestone: 1.10.8
Component: DojoX Mobile Version: 1.8.0
Keywords: Cc:
Blocked By: Blocking:

Description

When a scrollable list is already scrolling it doesn't stop when touched again. The user has to wait for the list to stop scrolling to regain control. This behavior doesn't work well with longer lists.

Change History (13)

comment:1 Changed 7 years ago by bill

Component: GeneralDojoX Mobile
Owner: set to Eric Durocher

comment:2 Changed 7 years ago by Eric Durocher

I can't reproduce this. Tried to modify dojox/mobile/tests/test_ScrollablePane_demo.html and added more items to one of the lists, the list stops as expected if I touch while scrolling (tested on iPhone).

Can you please give more details? Which device/OS, and ideally a simple code sample that reproduces the problem.

comment:3 Changed 7 years ago by Wouter Hager

I tested this on a desktop windows 7 /w firefox 14. incidentally, on android Firefox the demos don't work.

comment:4 Changed 7 years ago by Wouter Hager

When I reduce the timeout to reconnect onTouch to 200 msecs, I can clearly see the scrollable layer is still moving and not stopped when I click, causing a jerking of the content and scrollbar. I did this with noCover:true, because the cover will prevent the touch node from ever being reached until it is removed (is the cover still required when we have user-select and unselectable?).

_runSlideAnimation doesn't seem to be cancellable.

Same in Android native browser. Can't see why android firefox won't cooporate...

Last edited 7 years ago by Wouter Hager (previous) (diff)

comment:5 Changed 6 years ago by Patrick Ruzand

Owner: changed from Eric Durocher to Patrick Ruzand
Status: newassigned

comment:6 Changed 4 years ago by dylan

Milestone: tbd1.12
Resolution: patchwelcome
Status: assignedclosed

Given that no one has shown interest in creating a patch in the past 3+ years, I'm closing this as patchwelcome.

comment:7 Changed 3 years ago by dylan

Milestone: 1.131.12.2
Priority: undecidedlow
Resolution: patchwelcome
Status: closedreopened

comment:8 Changed 3 years ago by dylan

Owner: changed from Patrick Ruzand to dylan
Status: reopenedassigned

comment:9 Changed 3 years ago by dylans <dylan@…>

Resolution: fixed
Status: assignedclosed

In 277fd37/dojox:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:10 Changed 3 years ago by dylans <dylan@…>

In 9c522e74/dojox:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:11 Changed 3 years ago by dylans <dylan@…>

In 60b7e0d/dojox:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:12 Changed 3 years ago by dylans <dylan@…>

In 9eb929e/dojox:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:13 Changed 3 years ago by dylan

Milestone: 1.12.21.10.8
Note: See TracTickets for help on using tickets.