Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#15838 closed defect (fixed)

[regression] Tree: click and scroll broken on mobile

Reported by: bill Owned by: bill
Priority: undecided Milestone: 1.8.1
Component: Dijit Version: 1.8.0
Keywords: Cc:
Blocked By: Blocking:

Description

Judging from the API viewer, looks like both clicking a tree is broken (no effect), and scrolling is broken (dragging up/down, either with one finger or two fingers, doesn't scroll the Tree.

Change History (6)

comment:1 Changed 7 years ago by bill

Milestone: tbd1.8.1
Summary: Tree: click and scroll broken on mobile[regression] Tree: click and scroll broken on mobile

Click broken in #15185 ([28381]), can be seen on test_Tree.html (no messages to console on leaf node click). tree/_dndSelector.onMouseDown() calls evt.preventDefault() on the touchstart event, which prevents the click event from firing, and presumably also prevents scroll.

Last edited 7 years ago by bill (previous) (diff)

comment:2 Changed 7 years ago by bill

In [29475]:

Don't call evt.preventDefault() on touchstart, since on mobile, it prevents the click event and also scrolling. Refs #15838 on trunk/ !strict.

Scrolling still doesn't work perfectly on mobile:

  • touchstart selects a tree node, even though I'm just trying to scroll the tree
  • as the tree scrolls, whenever a tree node moves under the *original* position of my finger, it becomes highlighted, and then on touchstart the node under the original position of my finger is selected

comment:3 Changed 7 years ago by bill

In [29476]:

Don't monitor mouseover/mouseout on mobile, since you get misleading events when drag-scrolling. Refs #15838, fixing it on trunk, !strict.

comment:4 Changed 7 years ago by bill

Resolution: fixed
Status: newclosed

In [29482]:

backport [29745] and [29746] to 1.8 branch, fixes #15838 on 1.8/ branch !strict.

comment:5 Changed 6 years ago by bill

In [29939]:

Prevent text selection while dragging on desktop, fixes #16328 on trunk/ !strict. But continue to *not* call preventDefault() on mobile because it will break things completely, refs #15838.

comment:6 Changed 6 years ago by bill

In [29940]:

Prevent text selection while dragging on desktop, fixes #16328 on 1.8/ branch !strict. But continue to *not* call preventDefault() on mobile because it will break things completely, refs #15838.

Note: See TracTickets for help on using tickets.