Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#15836 closed defect (invalid)

FilteringSelect on Android

Reported by: Pete Smith Owned by: Pete Smith
Priority: undecided Milestone: tbd
Component: Dijit - Form Version: 1.8.0
Keywords: Cc:
Blocked By: Blocking:

Description

If you fire up the default dijit test page for the FilteringSelect?, and try to select an item in the list, you will see a strange behavior. Touch the first item, and it works fine. Touch the third item, and it will bounce the selection down to the eighth. Yikes. This is even with no theme / just vanilla dijit.css. There is some bizarre focus green highlighting going on, which seems to make me think that the div structure is not good. We use a table on the other menus, so I don't know why we don't go for a <ul> list or table. I just did this with the latest 1.8 RC, but it also does this on 1.7.3.

Change History (5)

comment:1 Changed 7 years ago by Douglas Hays

Owner: changed from Douglas Hays to Pete Smith
Status: newpending

Touching any displayed menu item is working perfectly for me on 1.8.0. I did notice that menu scrolling is not working with touch events. Please provide more details about what/how you're testing and your test environment. I'm testing on Android Xoom tablet v3.2.1 (tried both orientations).
I'm testing with the first box using
http://download.dojotoolkit.org/release-1.8.0/dojo-release-1.8.0/dijit/tests/form/test_FilteringSelect.html
The green highlighting in the textbox is an Android convention for selected text.

comment:2 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

comment:3 Changed 7 years ago by Pete Smith

I haven't had a chance to get back to this, I am going to upgrade the app to 1.8 and hope that it works. If it doesn't, I will reopen this.

comment:4 Changed 7 years ago by Pete Smith

I have upgraded our app to the latest 1.8.0 release. This behavior is exactly the same. You touch the third item in the list and the selection hops down. I am on an Android 2.3.4 HTC Phone.

comment:5 Changed 6 years ago by bill

FYI, I also tried both test_FilteringSelect.html and mobile.html on an Android 2.3.4 phone (SBM009SH), and selecting the third item, "American Samoa", worked fine for me.

Note: See TracTickets for help on using tickets.