Opened 7 years ago

Closed 7 years ago

#15833 closed defect (invalid)

Mobile - Loading external view problem

Reported by: richyevans Owned by: Eric Durocher
Priority: undecided Milestone: tbd
Component: DojoX Mobile Version: 1.8.0rc2
Keywords: Cc:
Blocked By: Blocking:

Description

I'm using Dojo 1.8 rc2. I've logged an issue on the community forum.

http://dojo-toolkit.33424.n3.nabble.com/Mobile-Loading-external-view-problem-tp3988281.html;cid=1344593623226-51

I'm really struggling to be able to do transitions or moveto's in sub groups.

Can someone look to see if this is a bug? I've tried everything I can think of to get this to work. I'd like to see external views work as it speeds our startup time and allows us to have smaller html files to make up the application. I use sub groups to segregate visibility of a tab bar.

If this is not a bug, can someone take my example and make it work. I'm more than happy to explain if the example is not clear.

Change History (4)

comment:1 Changed 7 years ago by Adrian Vasiliu

You have tried using a dojox.mobile.View as target container for loading the external view and a dojox.mobile.ScrollableView at the top of the external view. In my experiments, the trouble with the RoundRectCategory being badly placed goes away by doing the opposite, that is a dojox.mobile.View at the top of the external view and a scrollable view as target. We will see if this limitation can be removed (if not, it will be better documented).

Also, in the HTML of the current jsfiddle the target view (id="subgroup") has already the content declared in markup (the view with id="view3" and its children). I'm not sure what's the intention here, but I would think it should rather be empty, since the content is to be loaded from the external fragment.

comment:2 Changed 7 years ago by Adrian Vasiliu

Tested OK the solution suggested by ykami on dojo-interest, which is to load the external view only after ensuring that the view which contains the target container is visible:

"That can happen if you dynamically create a ScrollableView under hidden state (display=none), because the browser does not return correct dimension in such situation. This may not be an ideal solution, but you can avoid the problem by doing this before calling openExternalView(): registry.byId("group").show();"

So this does the trick for the correct layout of the scrollable view in the external view. For user's convenience, maybe it would make sense to do it automatically.

comment:3 Changed 7 years ago by richyevans

The suggestion works, so please close this defect if you think appropriate. I just need to understand how to manage my views when I have to have the target container visible when I don't want it to be visible :)

Last edited 7 years ago by richyevans (previous) (diff)

comment:4 Changed 7 years ago by Eric Durocher

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.