Opened 7 years ago

Closed 7 years ago

#15824 closed defect (invalid)

test_EdgeToEdgeList-editable-a11y.html: reordering last items is not possible

Reported by: Damien Mandrioli Owned by: cjolif
Priority: undecided Milestone: 1.9
Component: DojoX Mobile Version: 1.8.0rc1
Keywords: Cc:
Blocked By: Blocking:

Description

OS affected: All

  1. Run dojox/mobile/tests/test_EdgeToEdgeList-editable-a11y.html
  2. Click 'Edit' button
  3. Scroll down the page
  4. Try to move up 'Item l', it's not possible, the item does not move

Note: Should be fixed by replacing the main View by a ScrollableView?, like in test_EdgeToEdgeList-editable-sv.html which works correctly.

Attachments (1)

patch15824.patch (2.0 KB) - added by Damien Mandrioli 7 years ago.
[IBMCCLA]

Download all attachments as: .zip

Change History (9)

comment:1 Changed 7 years ago by Damien Mandrioli

Same problem with test_EdgeToEdgeList-editable.html

Changed 7 years ago by Damien Mandrioli

Attachment: patch15824.patch added

[IBMCCLA]

comment:2 Changed 7 years ago by cjolif

Milestone: tbd1.9
Owner: changed from Eric Durocher to cjolif
Status: newassigned

comment:3 Changed 7 years ago by cjolif

Resolution: fixed
Status: assignedclosed

In [29535]:

fixes #15824. Fixes test cases. Thanks Damien Mandrioli (IBM, CCLA).

comment:4 Changed 7 years ago by ykami

Resolution: fixed
Status: closedreopened

test_EdgeToEdgeList-editable.html (and test_EdgeToEdgeList-editable-a11y.html) is a test case for editable list on View, while test_EdgeToEdgeList-editable-sv.html is a test case for editable list on ScrollableView. Changing View in test_EdgeToEdgeList-editable.html to ScrollableView is not a solution.

comment:5 Changed 7 years ago by cjolif

In [29585]:

refs #15824. Backtrack on [29535] as ykami said the test is actually correct.

comment:6 Changed 7 years ago by ykami

Yes, the test cases are correct. Fixing them would hide the real problem. Note that -sv of test_EdgeToEdgeList-editable-sv.html stands for "ScrollableView".

BTW, I was not able to reproduce the problem on my Chrome. Am I missing something? Or perhaps you didn't notice there was Item k below Item l because of the scroll position?

comment:7 Changed 7 years ago by Damien Mandrioli

Finally I don't reproduce! Sorry, you can close the bug...

comment:8 Changed 7 years ago by cjolif

Resolution: invalid
Status: reopenedclosed
Note: See TracTickets for help on using tickets.