Opened 7 years ago

Closed 7 years ago

#15823 closed defect (duplicate)

TypeError in dojo/request

Reported by: Alexander Kläser Owned by:
Priority: undecided Milestone: tbd
Component: IO Version: 1.8.0rc1
Keywords: Cc:
Blocked By: Blocking:

Description

The following bit of code does currently fail with Dojo 1.8rc:

require(dojo/request?, function(request){

request("request.html");

});

I would get a TypeError?: Cannot read property 'data' of undefined. The error seems to be in xhr.js:

function xhr(/*String*/ url, /*Object?*/ options, /*Boolean?*/ returnDeferred) {

var response = util.parseArgs(

url, util.deepCreate(defaultOptions, options), has('native-formdata') && options.data && options.data instanceof FormData?);

...

options.data would yield this error, albeit options is not necessarily defined.

Change History (1)

comment:1 Changed 7 years ago by bill

Component: GeneralIO
Resolution: duplicate
Status: newclosed

Duplicate of #15736.

Note: See TracTickets for help on using tickets.