Opened 7 years ago

Closed 7 years ago

#15817 closed defect (fixed)

ListItem transitions when scrolling

Reported by: kbenjamin Owned by: Eric Durocher
Priority: undecided Milestone: 1.8
Component: DojoX Mobile Version: 1.8.0rc1
Keywords: Cc:
Blocked By: Blocking:

Description

Actually, 1.8rc2 but there isn't a choice for that.

When you have more than a screenful of ListItem? widgets and try to touch scroll through them they often fire the onClick event i.e. moveTo, instead of only scrolling.

See: http://dojo-toolkit.33424.n3.nabble.com/dojox-mobile-EdgeToEdgeList-and-scrolling-questions-tp3988360p3988386.html

Attachments (2)

test_trac15817.html (12.1 KB) - added by Adrian Vasiliu 7 years ago.
Test case to reproduce.
patch15817.patch (2.0 KB) - added by Adrian Vasiliu 7 years ago.
Getting rid of dojo/touch from dojox/mobile/_ItemBase - Adrian Vasiliu, IBM, CCLA

Download all attachments as: .zip

Change History (8)

Changed 7 years ago by Adrian Vasiliu

Attachment: test_trac15817.html added

Test case to reproduce.

comment:1 Changed 7 years ago by Adrian Vasiliu

The attached test_trac15817.html is a modified version of dojox/mobile/tests/test_ListItem-actions.html. The differences: increased number of items in the first list such that they don't fit in the screen height on either phones or tablets, thus forcing a browser scroll; also, the transitions are based on "moveTo" instead of onclick actions (however the bug hurts in both cases).

How to reproduce: load the file on a mobile device and scroll a couple of times. After only a few scrolling gestures, a view transition is triggered, while it shouldn't.

I reproduce with iPhone 4S iOS 5.0.1, iPad 2 iOS 5.1.1, Galaxy Tab Android 2.2. Apparently hurts all mobile devices. Not reproducible on desktop browsers (specific to touch-enabled devices).

Appears to be a side-effect of changes in dojo/touch.js. In any case, reverting touch.js to rev. 26731 (5 months old), the issue is NOT reproducible anymore. We will see how to deal with it.

Last edited 7 years ago by Adrian Vasiliu (previous) (diff)

comment:2 Changed 7 years ago by Adrian Vasiliu

Update:

More exactly, the trouble is since rev. 28381 of dojo/touch.js. This will be reported separately (as a dojo/touch issue; a symptom can be reproduced using dojo/tests/test_touch.html).

On our side, we will probably go for getting rid of using dojo/touch in _ItemBase.

comment:3 Changed 7 years ago by Eric Durocher

The root cause is this: #15821

Changed 7 years ago by Adrian Vasiliu

Attachment: patch15817.patch added

Getting rid of dojo/touch from dojox/mobile/_ItemBase - Adrian Vasiliu, IBM, CCLA

comment:4 Changed 7 years ago by Adrian Vasiliu

The attached patch15817.patch gets rid of the use of dojo/touch in dojox/mobile/_ItemBase. This fixes the trouble reported in this ticket. As agreed with edurocher, we may use this solution in case we need a quick workaround waiting for the fix in dojo/touch.

comment:5 Changed 7 years ago by Eric Durocher

By the way, since the bug occurs only when native browser scrolling is used, a quick and easy workaround is to replace the toplevel View by a ScrollableView.

comment:6 Changed 7 years ago by bill

Milestone: tbd1.8
Resolution: fixed
Status: newclosed

I fixed #15821 so this is fixed too.

Note: See TracTickets for help on using tickets.