Opened 7 years ago

Closed 7 years ago

#15806 closed defect (fixed)

dojox/mobile/Heading test failure (chrome/win)

Reported by: bill Owned by: Eric Durocher
Priority: undecided Milestone: 1.8.1
Component: DojoX Mobile Version: 1.8.0
Keywords: dohfail Cc:
Blocked By: Blocking:

Description

GROUP "dojox.mobile.test.doh.Heading" has 2 tests to run
     _AssertFailure: assertEqual() failed:
 	expected
		mblToolBarButtonArrow mblToolBarButtonLeftArrow
	but got
		mblToolBarButtonArrow mblToolBarButtonLeftArrow mblColorDefault mblColorDefault45

     ERROR IN:
 		 function (){
						var widget1 = _createHeadingDeclaratively("dojox_mobile_Heading_0");
						var widget2 = _createHeadingProgrammatically("view1-Heading2place", "view1-Heading2", WIDGET_TITLE_TEXT1);
						var widget3 = _createHeadingProgrammaticallyWithSourceNodeReference("view1-Heading3");

						_assertCorrectHeading(widget1, WIDGET_TITLE_TEXT1, WIDGET_BACK_TEXT, WIDGET_BUTTON_CLASSNAME);
						_assertCorrectHeading(widget2, WIDGET_TITLE_TEXT1, WIDGET_BACK_TEXT, WIDGET_BUTTON_CLASSNAME);
						_assertCorrectHeading(widget3, WIDGET_TITLE_TEXT1, WIDGET_BACK_TEXT, WIDGET_BUTTON_CLASSNAME);

					}
 FAILED test: ../../dojox/mobile/tests/doh/HeadingTests.html::dojox.mobile.test.doh.Heading::Heading Verification1 4 ms
     _AssertFailure: assertEqual() failed:
 	expected
		mblToolBarButtonArrow mblToolBarButtonLeftArrow
	but got
		mblToolBarButtonArrow mblToolBarButtonLeftArrow mblColorDefault mblColorDefault45

     ERROR IN:
 		 function (){
						var widget1 = _createHeadingDeclaratively("dojox_mobile_Heading_1");
						var widget2 = _createHeadingProgrammatically("view2-Heading2place", "view2-Heading2", WIDGET_TITLE_TEXT2);
						var widget3 = _createHeadingProgrammaticallyWithSourceNodeReference("view2-Heading3");

						var d = new runner.Deferred();
						var handle2 = dojo.subscribe("/dojox/mobile/afterTransitionIn", d.getTestCallback(function(view){
							if(view.id=="view2"){
								dojo.unsubscribe(handle2);
							}
							var widget1 = registry.byId("dojox_mobile_Heading_1");
							var widget2 = registry.byId("view2-Heading2");
							var widget3 = registry.byId("view2-Heading3");
							_assertCorrectHeading(widget1, WIDGET_TITLE_TEXT2, WIDGET_BACK_TEXT, WIDGET_BUTTON_CLASSNAME);
							_assertCorrectHeading(widget2, WIDGET_TITLE_TEXT2, WIDGET_BACK_TEXT, WIDGET_BUTTON_CLASSNAME);
							_assertCorrectHeading(widget3, WIDGET_TITLE_TEXT2, WIDGET_BACK_TEXT, WIDGET_BUTTON_CLASSNAME);
						}));
						_showView2();
						return d;
					}
 FAILED test: ../../dojox/mobile/tests/doh/HeadingTests.html::dojox.mobile.test.doh.Heading::Heading Verification2 12 ms

Attachments (2)

patch15806.patch (817 bytes) - added by Adrian Vasiliu 7 years ago.
Adjust the test after recent changes to fix #15675 - Adrian Vasiliu, IBM, CCLA
patch15806_IE.patch (2.5 KB) - added by Adrian Vasiliu 7 years ago.
Fix the test for IE. The library changes introduced in #15675 and which were breaking the test on browsers such as Chrome do not hold for IE. Hence, the test must do a different check on IE. This is what patch15806_IE.patch does. - Adrian Vasiliu, IBM, CCLA

Download all attachments as: .zip

Change History (13)

comment:1 Changed 7 years ago by bill

Keywords: dohfail added

Looks like an intermittent failure; it didn't reproduce for me standalone, but did reproduce from runTests.html.

Changed 7 years ago by Adrian Vasiliu

Attachment: patch15806.patch added

Adjust the test after recent changes to fix #15675 - Adrian Vasiliu, IBM, CCLA

comment:2 Changed 7 years ago by Adrian Vasiliu

Running doh/HeadingTests.html standalone, it fails systematically (with the same error messages) in my Chrome 20 and Chrome 21 on Win7.

These failures are side-effects of the recent fix for #15675 .

The attached patch15806.patch is likely to be the correct fix of the errors: just updating the test to consider two newly introduced CSS classes. To be double-checked by the main owners of the fix for #15675 .

comment:3 Changed 7 years ago by ykami

Adrian, the patch looks good to me. It should have been updated with #15675. Thank you.

comment:4 Changed 7 years ago by cjolif

In [29516]:

refs #15806. Fix the test for trunk. Thanks Adrian Vasiliu (IBM, CCLA).

comment:5 Changed 7 years ago by cjolif

In [29517]:

refs #15806. Remove wrongly committed file.

comment:6 Changed 7 years ago by cjolif

Milestone: tbd1.8.1
Version: 1.7.31.8.0

comment:7 Changed 7 years ago by cjolif

Resolution: fixed
Status: newclosed

In [29518]:

fixes #15806. Fix the test for 1.8 branch. Thanks Adrian Vasiliu (IBM, CCLA).

comment:8 Changed 7 years ago by Adrian Vasiliu

As a matter of fact, the library changes introduced in #15675 and which were breaking the test on browsers such as Chrome do not hold for IE. Hence, the test must do a different check on IE. This is what patch15806_IE.patch does.

comment:9 Changed 7 years ago by cjolif

Resolution: fixed
Status: closedreopened

Changed 7 years ago by Adrian Vasiliu

Attachment: patch15806_IE.patch added

Fix the test for IE. The library changes introduced in #15675 and which were breaking the test on browsers such as Chrome do not hold for IE. Hence, the test must do a different check on IE. This is what patch15806_IE.patch does. - Adrian Vasiliu, IBM, CCLA

comment:10 Changed 7 years ago by cjolif

In [29631]:

refs #15806. Fix the test case for IE. Thanks Adrian Vasiliu (IBM, CCLA).

comment:11 Changed 7 years ago by cjolif

Resolution: fixed
Status: reopenedclosed

In [29632]:

fixes #15806. Fix the test case for IE. Thanks Adrian Vasiliu (IBM, CCLA).

Note: See TracTickets for help on using tickets.