Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#15805 closed defect (fixed)

dojox/mobile/EdgeToEdgeCategory test failure (chrome/win)

Reported by: bill Owned by: Eric Durocher
Priority: undecided Milestone: 1.8.1
Component: DojoX Mobile Version: 1.8.0rc2
Keywords: dohfail Cc:
Blocked By: Blocking:

Description

    Error: test timeout in ../../dojox/mobile/tests/doh/EdgeToEdgeCategory.html::dojox.mobile.test.doh.EdgeToEdgeList::EdgeToEdgeList Verification2
     ERROR IN:
 		 function (){
				var d = new doh.Deferred();
				var demoWidget = dijit.byId("dojox_mobile_EdgeToEdgeList_0");
				demoWidget.set({transition :"flip"});
				doh.assertEqual("flip", demoWidget.get("transition"));
				demoWidget.set({transition :"fade"});
				doh.assertEqual("fade", demoWidget.get("transition"));

				fireOnMouseDown("item3");
				fireOnMouseUp("item3");
				var view = dijit.byId("foo");
				dojo.connect(view, "onAfterTransitionOut", this, d.getTestCallback(function(){
					var demoWidget = dijit.byId("dojox_mobile_EdgeToEdgeCategory_0");
					doh.assertEqual('mblEdgeToEdgeCategory', demoWidget.domNode.className);
					doh.assertEqual('Applications', demoWidget.domNode.innerHTML);

					demoWidget = dijit.byId("dojox_mobile_EdgeToEdgeList_1");
					doh.assertEqual('mblEdgeToEdgeList', demoWidget.domNode.className);

					verifyListItem("dojox_mobile_ListItem_0", 'Video', 'Off', "", false, false, false);
					verifyListItem("dojox_mobile_ListItem_1", 'Maps', 'VPN', "", true, false, false);
					verifyListItem("dojox_mobile_ListItem_2", 'Phone Number', 'Off', "", false, false, false);
				}));
				return d;
			}
 FAILED test: ../../dojox/mobile/tests/doh/EdgeToEdgeCategory.html::dojox.mobile.test.doh.EdgeToEdgeList::EdgeToEdgeList Verification2 1255 ms

Attachments (1)

patch15805.patch (489 bytes) - added by Adrian Vasiliu 7 years ago.
Increased timeout - Adrian Vasiliu, IBM, CCLA

Download all attachments as: .zip

Change History (8)

comment:1 Changed 7 years ago by bill

Keywords: dohfail added

Looks like an intermittent failure; it didn't reproduce for me standalone.

comment:2 Changed 7 years ago by Adrian Vasiliu

I tried doh/EdgeToEdgeCategory.html a number of times standalone, and also inside runTests.html, with fresh installs of 1) 1.7.3 and 2) 1.8rc2. It always succeeded on Chrome 21 / Win7.

bill, did you reproduce (intermittently) with 1.7.3 as marked in the ticket? Or was it with a RC of 1.8? Do you still reproduce with 1.8 rc2?

comment:3 Changed 7 years ago by bill

Version: 1.7.31.8.0rc2

It happened on trunk, from runTests.html, and I just reproduced it on the latest code (restart chrome them immediately run runTests.html). Probably you just need to increase the test timeout (the default is 1000ms).

Changed 7 years ago by Adrian Vasiliu

Attachment: patch15805.patch added

Increased timeout - Adrian Vasiliu, IBM, CCLA

comment:4 Changed 7 years ago by Adrian Vasiliu

On my side, with a freshly restarted Chrome 21 and a freshly updated trunk, it passes OK, both standalone and inside runTests.html. On my machine it uses less than half of the 1000 ms. To make it pass on slower machines let's increase the timeout as you say - done in the attached patch15805.patch.

comment:5 Changed 7 years ago by cjolif

In [29533]:

refs #15805. Increased timeout, Thanks Adrian Vasiliu, IBM, CCLA

comment:6 Changed 7 years ago by cjolif

Resolution: fixed
Status: newclosed

In [29534]:

fixes #15805. Increased timeout, Thanks Adrian Vasiliu, IBM, CCLA

comment:7 Changed 7 years ago by cjolif

Milestone: tbd1.8.1
Note: See TracTickets for help on using tickets.