Opened 14 years ago

Closed 14 years ago

#158 closed defect (duplicate)

Checkbox values being submitted whether or not they're checked

Reported by: webmaster@… Owned by: anonymous
Priority: high Milestone:
Component: General Version: 0.1
Keywords: Cc:
Blocked By: Blocking:

Description

when passing a form element that contains a checkbox, the value still goes through even though it is checked off.

here's the line at fault (in dojo.js, line 879):

if(dojo.alg.inArray(type,["radio","checked"])){

it should be:

if(dojo.alg.inArray(type,["radio","checkbox"])){

Change History (1)

comment:1 Changed 14 years ago by david

Resolution: duplicate
Status: newclosed

Duplicate of #126 which has been fixed as of rev [1645].

Note: See TracTickets for help on using tickets.