Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#15799 closed defect (fixed)

tests/_base/query.html failure (IE9)

Reported by: bill Owned by: Kris Zyp
Priority: undecided Milestone: 1.6.2
Component: Query Version: 1.6.1
Keywords: dohfail Cc: cjolif
Blocked By: Blocking:

Description

    _AssertFailure: assertEqual() failed: 	expected
		1
	but got
		2

     ERROR IN: 		 function anonymous(t) {
doh.is(1, dojo.query('.fooBar').length);
} FAILED test: ../../dojo/tests/_base/query.html::t::doh.is(1, dojo.query('.fooBar').length); 0 ms

Change History (7)

comment:1 Changed 7 years ago by bill

Keywords: dohfail added

This isn't happening when the test is run standalone, so it's possibly just another DOH problem because the outer window forces the iframe into standards mode. Although I can't reproduce the failure even when I tweak the document type through the developer console.

comment:2 Changed 7 years ago by Kris Zyp

Resolution: fixed
Status: newclosed

In [29427]:

All browsers exhibit case sensitivity when in quirks mode, not just mozilla and webkit, fixes #15799 !strict

comment:3 Changed 7 years ago by bill

Milestone: tbd1.8

comment:4 Changed 7 years ago by cjolif

Cc: cjolif added

comment:5 Changed 7 years ago by cjolif

In [30356]:

refs #15799. 1.7 backport of IE9 fix. !strict.

comment:6 Changed 7 years ago by cjolif

In [30357]:

refs #15799. 1.6 backport for IE9 fix. !strict.

comment:7 Changed 7 years ago by cjolif

Milestone: 1.81.6.2
Version: 1.7.31.6.1
Note: See TracTickets for help on using tickets.