Opened 7 years ago

Closed 7 years ago

Last modified 5 years ago

#15793 closed defect (fixed)

[regression] TitlePane: cannot toggle via ENTER key (IE9)

Reported by: bill Owned by: bill
Priority: undecided Milestone: 1.7.6
Component: Dijit Version: 1.8.0rc1
Keywords: Cc: Kris Zyp
Blocked By: Blocking:

Description

TitlePane will toggle via click or SPACE key, but not ENTER key. Works in 1.7 but fails on trunk.

Change History (9)

comment:1 Changed 7 years ago by bill

Cc: Kris Zyp added
Milestone: tbd1.8
Status: newassigned

Another problem caused by the issue with dojo.connect()'s synthetic keypress event on IE9, see #15709. I will workaround it in the same way as I did there.

comment:2 Changed 7 years ago by bill

Resolution: fixed
Status: assignedclosed

In [29420]:

fix ENTER key toggle on IE9, fixes #15793 !strict.

comment:3 Changed 6 years ago by bill

On further inspection, I think that when TitlePane was using the synthetic onkeypress event, it was failing because of the <button> nodes in the test file. Seems that since those nodes don't have a type specified, they default to type=submit, which somehow blocks the native keypress event from occurring. It just happened to work before #14954 was fixed because there was still the faux event created by the dojo.connect() code's synthetic keypress event.

The change to use keydown rather than keypress is an improvement anyway since it would have been needed for the 2.0 transition, where we drop dojo.connect(), but it wasn't necessary to fix the problem, since it was more of a problem with the test case.

comment:4 Changed 6 years ago by bill

In [30342]:

fix type of buttons in test_TitlePane.html test file, refs #15793

comment:5 Changed 6 years ago by bill

In [30343]:

fix type of buttons in test_TitlePane.html test file (1.8 branch), refs #15793

comment:6 Changed 6 years ago by haysmark

This was working in 1.6 and 1.7 branches so doesn't need to be backported.

comment:7 Changed 6 years ago by bill

Agreed, although on the 1.7 branch it's working in a fragile way. See #14954. The reason it's working is because of the event.stop() call in TitlePane._onTitleKey(). It's also working because of the <button> nodes in the test file, see #16570.

comment:8 Changed 5 years ago by Bill Keese <bill@…>

In 661d58249f4be8a0c33233511243de05edd392d2/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:9 Changed 5 years ago by bill

Milestone: 1.81.7.6
Note: See TracTickets for help on using tickets.