Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#15772 closed defect (invalid)

packages.location ignored since [29249]

Reported by: sirprize Owned by: Rawld Gill
Priority: undecided Milestone: tbd
Component: Loader Version:
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by bill)

The following configuration has stopped working on [29249] (07/15/12):

var dojoConfig = {
    async: 1,
    packages: [
        { name: 'my/backend', location: '/media/scripts/lib/my/backend' }
    ]
};

The loader seems to ignore the 'location' property and is now looking for custom modules in the dojo dir:

my.localhost/vendor/dojo/dev-master/my/backend/app/App.js

Change History (3)

comment:1 Changed 7 years ago by bill

Description: modified (diff)
Summary: Changed loader behaviourpackages.location ignored since [29249]

comment:2 Changed 7 years ago by Colin Snover

Resolution: invalid
Status: newclosed

Hi,

Thanks for the report but this doesn’t appear to be a Dojo bug. According to the AMD draft spec (https://github.com/amdjs/amdjs-api/wiki/Common-Config), a package name is the first segment of an absolute module ID. In other words, it cannot have a "/" in it. The fact that this may have worked in earlier versions of Dojo was simply a bug in the loader.

If you change your package name to something without a slash in it and this problem still occurs, please let us know. Thanks!

comment:3 Changed 7 years ago by bill

#16294 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.